@component_name

Программный интерфейс системы PDM STEP Suite

Библиотека: APL_PSS_API

ActiveX компонент, предназначенный для работы с базой данных системы PDM Step Suite (компонент AplAPI) и содержащий дополнительные возможности для оптимизации программ.

Файл библиотеки: APL_PSS_API.dll

Компоненты:

AplPssAPI | Компонент для работы с базой данных PSS
AplLongMap | Карта (Map) для связи уникальных ключей с типом целое число с полями с типом целое число
AplStringMap | Карта (Map) для связи уникальных ключей с типом строка с полями с типом целое число

© НИЦ CALS-технологий "Прикладная логистика"


AplPssAPI

Компонент: AplPssAPI

Компонент для работы с базой данных PSS

ProgID: APL_PSS_API.AplPssAPI

Предоставляемые интерфейсы:

IAplAPI | Общие методы работы с БД
IAplAPI_Data | Методы для работы с локальным кэшем
IAplAPI_Folder | Методы для работы с папками
IAplAPI_Category | Методы для работы с категориями
IAplAPI_Document | Методы для работы с документами
IAplAPI_Product | Методы для работы с изделиями
IAplAPI_Autorization | Методы для работы с организационной структурой
IAplAPI_BProcess | Методы для работы с бизнесс-процессам
IAplAPI_Characteristic | Методы для работы с характеристиками и единицами измерения

Пример использования:

'Объявление компонента и интерфейсов
Dim AplPssAPI As Object
Dim PssData     As IAplAPI_Data
Dim PssFolder   As IAplAPI_Folder
Dim PssCateg    As IAplAPI_Category
Dim PssDoc      As IAplAPI_Document
Dim PssProduct  As IAplAPI_Product
Dim PssAutoriz  As IAplAPI_Autorization
Dim PssBP       As IAplAPI_BProcess
Dim PssCharact  As IAplAPI_Characteristic

'Создание компонента
Set AplPssAPI = CreateObject(APL_PSS_API.AplPssAPI)

'Инициализация интерфейсов
Set PssData = AplPssAPI
Set PssFolder = AplPssAPI
Set PssCateg = AplPssAPI
Set PssDoc = AplPssAPI
Set PssProduct = AplPssAPI
Set PssAutoriz = AplPssAPI
Set PssBP = AplPssAPI
Set PssCharact = AplPssAPI

Dim pdf As Long, prd As Long
Dim buf, id, name, ver As String

AplPssAPI.AutoSave = 0  ' Автоматически в БД не сохранять
AplPssAPI.ModeInteractive = 1 ' Выводить все диалоги

AplPssAPI.Connect , ,

If True = AplPssAPI.IsConnected() Then
    'Выбираем в базе изделие
    pdf = AplPssAPI.SelectInstance(4, root)
    If pdf <> 0 Then
        'Получаем все версии изделия
        PssProduct.GetAllProductVersion pdf, pdfs
        For i = 0 To UBound(pdfs)
            'Получаем ссылку из версии изделия на изделие
            prd = PssData.GetAttrBN(pdfs(i), of_product)
            'Получаем обозначение версии изделия
            ver = PssData.GetAttrBN(pdfs(i), id)
            'Получаем обозначение изделия
            id = PssData.GetAttrBN(prd, id)
            'Получаем наименование изделия
            name = PssData.GetAttrBN(prd, name)
            'Выводим сообщение с выбранными атрибутами
            buf = id +  :  + name +  :  + ver
            MsgBox buf
        Next i
    End If
End If
'Разрываем соединение
AplPssAPI.Disconnect

Смотри также:

Библиотека APL_PSS_API


IAplAPI

Интерфейс: IAplAPI

Общие методы работы с БД

GUID: {69A21B6E-286E-4FD7-AC87-8527A3BA9770}

Свойства интерфейса:

AutoSave | Включение или выключение автосохранения
ModeInteractive | Включение или выключение интерактивного режима
ErrorMode | Отключает или включает сообщения о системных ошибках
WarningMode | Отключает или включает сообщения о системных предупреждениях

Методы интерфейса:

Connect | Устанавливает соединение с базой данных.
Disconnect | Разрывает соединение с базой данных.
LoadEntityExtentFromDB | Читает из базы данных все объекты указанного типа
LoadExtentInfo | Читает атрибуты объектов в локальный кэш программы
IsConnected | Проверяет соединение с базой данных
QueryExecute | Выполняет запрос к базе данных
SetInstancesAccess | Устанавливает доступ на объекты базы данных
SaveChanges | Сохраняет изменения кэша в базу данных
SelectInstance | Выбор объекта из базы данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


@metod_name

Свойство:

IAplAPI::AutoSave

Тип: long

Доступ: Чтение - Запись

Описание:

Свойство для включения или выключения автосохранения при вызовах функций интерфейсов. Если имеет значение 1, в функциях автоматически вызывается сохранение изменений в базе данных. Если имеет значение 0, сохранение вызывается на усмотрение разработчиков.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


@metod_name

Свойство:

IAplAPI::ModeInteractive

Тип: long

Доступ: Чтение - Запись

Описание:

Включение или выключение интерактивного режима. Если установлено значение 1, выводятся диалоги и сообщения . Если установлено значение 0, диалоги и сообщения не выводятся. Режим 0 предназначен для работы в пакетном или серверном режимах.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


@metod_name

Свойство:

IAplAPI::ErrorMode

Тип: long

Доступ: Только запись

Описание:

Отключает или включает сообщения о системных ошибках. Если значение 1, сообщения выводятся. Если значение 0 , сообщения не выводятся.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


@metod_name

Свойство:

IAplAPI::WarningMode

Тип: long

Доступ: Только запись

Описание:

Отключает или включает сообщения о системных предупреждениях. Если значение 1, сообщения выводятся. Если значение 0 , сообщения не выводятся.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


Connect

Метод:

IAplAPI::Connect

Определение:

Синтакс IDL: | VARIANT Connect(BSTR userName, BSTR passWord, BSTR baseName);
Синтакс Basic: | Function Connect(userName As String; passWord As String; baseName As String) As Variant
Синтакс Pascal: | function Connect(userName: WideString; passWord: WideString; baseName: WideString): COleVariant;

Описание:

Устанавливает соединение с базой данных. Если хотя бы один из параметров не указан, выводится диалог запроса для уточнения входных параметров.

Результат: Возвращает True, если соединение установлено успешно, False в противном случае.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | userName | имя пользователя
[in] | BSTR | passWord | пароль пользователя для входа в систему
[in] | BSTR | baseName | имя подключения к удаленной базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


Disconnect

Метод:

IAplAPI::Disconnect

Определение:

Синтакс IDL: | VARIANT Disconnect();
Синтакс Basic: | Function Disconnect() As Variant
Синтакс Pascal: | function Disconnect(): COleVariant;

Описание:

Разрывает соединение с базой данных.

Результат: Возвращает True, если операция прошла успешно, False в противном случае.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


LoadEntityExtentFromDB

Метод:

IAplAPI::LoadEntityExtentFromDB

Определение:

Синтакс IDL: | VARIANT LoadEntityExtentFromDB(BSTR entity);
Синтакс Basic: | Function LoadEntityExtentFromDB(entity As String) As Variant
Синтакс Pascal: | function LoadEntityExtentFromDB(entity: WideString): COleVariant;

Описание:

Читает из базы данных все объекты указанного типа

Результат: Возвращает True при удачном вызове или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | entity | тип объектов, которые надо считать из базы данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


LoadExtentInfo

Метод:

IAplAPI::LoadExtentInfo

Определение:

Синтакс IDL: | VARIANT LoadExtentInfo(VARIANT ext);
Синтакс Basic: | Function LoadExtentInfo(ext As Variant) As Variant
Синтакс Pascal: | function LoadExtentInfo(ext: COleVariant): COleVariant;

Описание:

Читает атрибуты объектов в локальный кэш программы

Результат: Возвращает True, если удаление прошло успешно, False в противном случае

Параметры метода:

Специф. | Тип | Название | Описание
[in] | VARIANT | ext | массив объектов для которых нужно прочитать атрибуты

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


IsConnected

Метод:

IAplAPI::IsConnected

Определение:

Синтакс IDL: | VARIANT IsConnected();
Синтакс Basic: | Function IsConnected() As Variant
Синтакс Pascal: | function IsConnected(): COleVariant;

Описание:

Проверяет установлено ли соединение с базой данных

Результат: Возвращает True, если соединение установлено, False в противном случае

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


QueryExecute

Метод:

IAplAPI::QueryExecute

Определение:

Синтакс IDL: | VARIANT QueryExecute(BSTR queryString, BSTR* errorDescription, VARIANT* objArray, long showDlg);
Синтакс Basic: | Function QueryExecute(queryString As String; errorDescription As String; objArray As Variant; showDlg As Integer) As Variant
Синтакс Pascal: | function QueryExecute(queryString: WideString; out errorDescription: WideString; out objArray: COleVariant; showDlg: Integer): COleVariant;

Описание:

Выполняет запрос к базе данных

Результат: Возвращает True, если удаление прошло успешно, False в противном случае

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | queryString | строка запроса к базе данных
[out] | BSTR* | errorDescription | описание ошибки при обработке запроса
[out] | VARIANT* | objArray | массив объектов, найденных в базе данных
[in] | long | showDlg | параметр, который указывает, выводить или нет диалог для редактирования строки запроса в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


SetInstancesAccess

Метод:

IAplAPI::SetInstancesAccess

Определение:

Синтакс IDL: | VARIANT SetInstancesAccess(VARIANT instances, long userOrWG, long accessLevel);
Синтакс Basic: | Function SetInstancesAccess(instances As Variant; userOrWG As Integer; accessLevel As Integer) As Variant
Синтакс Pascal: | function SetInstancesAccess(instances: COleVariant; userOrWG: Integer; accessLevel: Integer): COleVariant;

Описание:

Устанавливает для пользователя или группы пользователей userOrWG уровень доступа accessLevel к объектам, заданным списком instances.

Специальные комбинации параметров:
userOrWG==-1 -- установка доступа по умолчанию и сброс индивидуального флага
userOrWG==0 -- надо выводить диалог с уточнением параметров

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | VARIANT | instances | список объектов, для которых назначается доступ
[in] | long | userOrWG | пользователь (группа пользователей), для которого назначается доступ
[in] | long | accessLevel | назначаемый уровень доступа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


SaveChanges

Метод:

IAplAPI::SaveChanges

Определение:

Синтакс IDL: | VARIANT SaveChanges();
Синтакс Basic: | Function SaveChanges() As Variant
Синтакс Pascal: | function SaveChanges(): COleVariant;

Описание:

Сохраняет изменения кэша в базу данных

Результат: Возвращает True, если изменения внесены успешно, False в противном случае.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


SelectInstance

Метод:

IAplAPI::SelectInstance

Определение:

Синтакс IDL: | VARIANT SelectInstance(long selectMode, VARIANT rootObjects, BSTR title);
Синтакс Basic: | Function SelectInstance(selectMode As Integer; rootObjects As Variant; title As String) As Variant
Синтакс Pascal: | function SelectInstance(selectMode: Integer; rootObjects: COleVariant; title: WideString): COleVariant;

Описание:

Выбор объекта из базы данных

Результат: Возвращает преобразованный к Long указатель на выбранный экземпляра объекта или 0 (нуль), если экземпляр объекта не выбран.

Параметры метода:

Специф. | Тип | Название | Описание
[in] long selectMode значение, которое определяет тип данных для выбора. Возможно сочетание (сложение) при формировании значения параметра:
1 - можно выбирать категорию;
2 - можно выбирать папку;
4 - можно выбирать изделие;
8 - можно выбирать версию изделия;
16 - можно выбирать документ;
32 – можно выбирать бизнес-процесс
64 – можно выбирать партию изделий;
128 – можно выбирать экземпляр изделия;
256 – можно выбирать версию документа;

4096 – можно выбирать организацию;
8192 – можно выбирать сотрудника организации (нельзя использовать вместе с флагом (значением) выбора сотрудника);
16384 – можно выбирать сотрудника (нельзя использовать вместе с флагом (значением) выбора сотрудника организации).

[in] | VARIANT | rootObjects | массив корневых объектов дерева выбора (если массив пустой, параметр игнорируется)
[in] | BSTR | title | заголовок диалога выбора объектов

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI


IAplAPI_Data

Интерфейс: IAplAPI_Data

Методы для работы с локальным кэшем

GUID: {3C63C8C6-B0F0-48E0-96BA-74537A39E44D}

Методы интерфейса:

Создание, чтение и изменение данных в кэше
Работа с типами объектов
Системные функции
Работа с файлами
Создание, чтение и изменение данных в кэше
CreateInstance | Создает экземпляр объекта указанного типа
DeleteInstance | Удаляет экземпляр объекта
GetAttrBN | Читает атрибут экземпляра объекта из базы данных (по наименованию)
GetAttr | Читает атрибут экземпляра объекта из базы данных
PutAttrBN | Устанавливает значение атрибута экземпляра объекта (по наименованию)
PutAttr | Устанавливает значение атрибута экземпляра объекта
GetEntityExtent | Возвращает в extent все экземпляры объектов указанного типа
GetEntityExtentBN | Возвращает в extent все экземпляры объектов указанного типа (по наименованию)
Работа с типами объектов
IsKindOfBN | Проверяет тип экземпляра объекта
GetInstanceType | Возвращает имя типа экземпляра объекта
GetEntityDefinition | Возвращает ссылку на тип объектов
GetEntityName | Возвращает наименование типа объекта
GetAttrDefinition | Возвращает ссылку на атрибут
GetAttrName | Возвращает наименование атрибута объекта
Системные функции
GetInstanceId | Возвращает внутренний идентификатор экземпляра объекта
GetInstanceById | Возвращает объект по внутреннему идентификатору
ClearData | Учищает локальный кэш
IsValidInstance | Проверяет объект базы данных
LoadSystemDictionary | Читает системный словарь
Работа с файлами
SaveToFile | Сохраняет данные кэша в файл
LoadFromFile | Читает данные из файла в кэш.
LoadP21 | Читает данные из стандартного обменного файла
SaveP21 | Сохраняет стандартный обменный файл

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


CreateInstance

Метод:

IAplAPI_Data::CreateInstance

Определение:

Синтакс IDL: | VARIANT CreateInstance(BSTR entity);
Синтакс Basic: | Function CreateInstance(entity As String) As Variant
Синтакс Pascal: | function CreateInstance(entity: WideString): COleVariant;

Описание:

Создает экземпляр объекта указанного типа. Чтобы изменения были сохранены и стали доступны другим пользователям, необходимо вызвать метод SaveChanges

Результат: Возвращает преобразованный к Long указатель на созданный экземпляр объекта или 0 (нуль) в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | entity | тип создаваемого экземпляра объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


DeleteInstance

Метод:

IAplAPI_Data::DeleteInstance

Определение:

Синтакс IDL: | VARIANT DeleteInstance(long instance);
Синтакс Basic: | Function DeleteInstance(instance As Integer) As Variant
Синтакс Pascal: | function DeleteInstance(instance: Integer): COleVariant;

Описание:

Удаляет экземпляр объекта. Чтобы изменения были сохранены и стали доступны другим пользователям, необходимо вызвать метод SaveChanges

Результат: Возвращает True, если удаление прошло успешно, False в противном случае

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetAttrBN

Метод:

IAplAPI_Data::GetAttrBN

Определение:

Синтакс IDL: | VARIANT GetAttrBN(long instance, BSTR attrName);
Синтакс Basic: | Function GetAttrBN(instance As Integer; attrName As String) As Variant
Синтакс Pascal: | function GetAttrBN(instance: Integer; attrName: WideString): COleVariant;

Описание:

Читает атрибут экземпляра объекта из базы данных. Работает только с локальным кэшом программы (атрибут должен быть предварительно загружен в кэш).

Результат: Значение атрибута экземпляра объекта

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на экземпляр объекта данных PDM Step Suite
[in] | BSTR | attrName | идентификатор атрибута экземпляра объекта; Каждый экземпляр объекта данных PDM Step Suite имеет свой определенный набор атрибутов. Каждый атрибут имеет уникальное имя, которое его однозначно идентифицирует, поэтому при доступе к атрибуту экземпляра объекта данных системы PDM Step Suite необходимо указать его имя

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetAttr

Метод:

IAplAPI_Data::GetAttr

Определение:

Синтакс IDL: | VARIANT GetAttr(long instance, long attrName);
Синтакс Basic: | Function GetAttr(instance As Integer; attrName As Integer) As Variant
Синтакс Pascal: | function GetAttr(instance: Integer; attrName: Integer): COleVariant;

Описание:

Читает атрибут экземпляра объекта из базы данных. Работает только с локальным кэшом программы (атрибут должен быть предварительно загружен в кэш).

Результат: Значение атрибута экземпляра объекта

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных PDM Step Suite
[in] | long | attrName | ссылка на атрибут объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


PutAttrBN

Метод:

IAplAPI_Data::PutAttrBN

Определение:

Синтакс IDL: | VARIANT PutAttrBN(long instance, BSTR attrName, VARIANT value);
Синтакс Basic: | Function PutAttrBN(instance As Integer; attrName As String; value As Variant) As Variant
Синтакс Pascal: | function PutAttrBN(instance: Integer; attrName: WideString; value: COleVariant): COleVariant;

Описание:

Устанавливает значение атрибута экземпляра объекта. Чтобы изменения были сохранены и стали доступны другим пользователям, необходимо вызвать метод SaveChanges.

Результат: Возвращает True, если изменения внесены успешно, False в противном случае.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта
 | BSTR | attrName | идентификатор атрибута экземпляра объекта
[in] | VARIANT | value | значение атрибута экземпляра объекта. Тип передаваемого значения может быть целым, дробным, булевым, строковым

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


PutAttr

Метод:

IAplAPI_Data::PutAttr

Определение:

Синтакс IDL: | VARIANT PutAttr(long instance, long attrName, VARIANT value);
Синтакс Basic: | Function PutAttr(instance As Integer; attrName As Integer; value As Variant) As Variant
Синтакс Pascal: | function PutAttr(instance: Integer; attrName: Integer; value: COleVariant): COleVariant;

Описание:

Устанавливает значение атрибута экземпляра объекта. Чтобы изменения были сохранены и стали доступны другим пользователям, необходимо вызвать метод SaveChanges.

Результат: Возвращает True, если изменения внесены успешно, False в противном случае.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта
 | long | attrName | ссылка на атрибут объекта
[in] | VARIANT | value | значение атрибута экземпляра объекта. Тип передаваемого значения может быть целым, дробным, булевым, строковым

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetEntityExtent

Метод:

IAplAPI_Data::GetEntityExtent

Определение:

Синтакс IDL: | VARIANT GetEntityExtent(long entity, VARIANT* extent);
Синтакс Basic: | Function GetEntityExtent(entity As Integer; extent As Variant) As Variant
Синтакс Pascal: | function GetEntityExtent(entity: Integer; out extent: COleVariant): COleVariant;

Описание:

Возвращает в extent все экземпляры объектов указанного типа находящиеся к кэше клиента

Результат: Возвращает True при удачном вызове или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | entity | ссылка на тип объектов базы данных
[out] | VARIANT* | extent | переменная типа Variant, в которою будет записан результирующий набор экземпляров объектов указанного типа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetEntityExtentBN

Метод:

IAplAPI_Data::GetEntityExtentBN

Определение:

Синтакс IDL: | VARIANT GetEntityExtentBN(BSTR entity, VARIANT* extent);
Синтакс Basic: | Function GetEntityExtentBN(entity As String; extent As Variant) As Variant
Синтакс Pascal: | function GetEntityExtentBN(entity: WideString; out extent: COleVariant): COleVariant;

Описание:

Возвращает в extent все экземпляры объектов указанного типа находящиеся к кэше клиента

Результат: Возвращает True при удачном вызове или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | entity | тип экземпляров объектов
[out] | VARIANT* | extent | переменная типа Variant, в которою будет записан результирующий набор экземпляров объектов указанного типа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


IsKindOfBN

Метод:

IAplAPI_Data::IsKindOfBN

Определение:

Синтакс IDL: | VARIANT IsKindOfBN(long instance, BSTR type);
Синтакс Basic: | Function IsKindOfBN(instance As Integer; type As String) As Variant
Синтакс Pascal: | function IsKindOfBN(instance: Integer; type: WideString): COleVariant;

Описание:

Проверяет тип экземпляра объекта с учетом наследования

Результат: Возвращает True, если совпадают, False в противном случае

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта данных
[in] | BSTR | type | тип, с которым надо сравнить тип экземпляра объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetInstanceType

Метод:

IAplAPI_Data::GetInstanceType

Определение:

Синтакс IDL: | VARIANT GetInstanceType(long instance);
Синтакс Basic: | Function GetInstanceType(instance As Integer) As Variant
Синтакс Pascal: | function GetInstanceType(instance: Integer): COleVariant;

Описание:

Возвращает имя типа экземпляра объекта

Результат: Возвращает UNICODE строку String, в которой содержится имя экземпляра объекта

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetEntityDefinition

Метод:

IAplAPI_Data::GetEntityDefinition

Определение:

Синтакс IDL: | long GetEntityDefinition(BSTR entityName);
Синтакс Basic: | Function GetEntityDefinition(entityName As String) As Integer
Синтакс Pascal: | function GetEntityDefinition(entityName: WideString): Integer;

Описание:

Возвращает ссылку на тип объектов базы данных

Результат: Возвращает ссылку на тип объектов базы данных или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | entityName | наименование типа объектов базы данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetEntityName

Метод:

IAplAPI_Data::GetEntityName

Определение:

Синтакс IDL: | VARIANT GetEntityName(long entity);
Синтакс Basic: | Function GetEntityName(entity As Integer) As Variant
Синтакс Pascal: | function GetEntityName(entity: Integer): COleVariant;

Описание:

Возвращает наименование типа объектов базы данных

Результат: Возвращает наименование типа

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | entity | ссылка на тип объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetAttrDefinition

Метод:

IAplAPI_Data::GetAttrDefinition

Определение:

Синтакс IDL: | long GetAttrDefinition(long entity, BSTR attrName);
Синтакс Basic: | Function GetAttrDefinition(entity As Integer; attrName As String) As Integer
Синтакс Pascal: | function GetAttrDefinition(entity: Integer; attrName: WideString): Integer;

Описание:

Возвращает ссылку на атрибут определенно типа объектов

Результат: Возвращает ссылку на атрибут или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | entity | ссылка на тип объектов базы данных
[in] | BSTR | attrName | наименование атрибута

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetAttrName

Метод:

IAplAPI_Data::GetAttrName

Определение:

Синтакс IDL: | VARIANT GetAttrName(long attr);
Синтакс Basic: | Function GetAttrName(attr As Integer) As Variant
Синтакс Pascal: | function GetAttrName(attr: Integer): COleVariant;

Описание:

Возвращает наименование атрибута объекта.

Результат: Возвращает наименование атрибута объекта.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | attr | ссылка на атрибут объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetInstanceId

Метод:

IAplAPI_Data::GetInstanceId

Определение:

Синтакс IDL: | VARIANT GetInstanceId(long instance);
Синтакс Basic: | Function GetInstanceId(instance As Integer) As Variant
Синтакс Pascal: | function GetInstanceId(instance: Integer): COleVariant;

Описание:

Возвращает внутренний идентификатор экземпляра объекта

Результат: Возвращает внутренний уникальный идентификатор объекта в базе данных

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | преобразованный к Long указатель на экземпляр объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


GetInstanceById

Метод:

IAplAPI_Data::GetInstanceById

Определение:

Синтакс IDL: | VARIANT GetInstanceById(long instId);
Синтакс Basic: | Function GetInstanceById(instId As Integer) As Variant
Синтакс Pascal: | function GetInstanceById(instId: Integer): COleVariant;

Описание:

Возвращает ссылку на объект в базе данных по его внутреннему идентификатору

Результат: Ссылка на объект при удачном выполнении и NULL в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instId | Уникальный идентификатор объекта в базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


ClearData

Метод:

IAplAPI_Data::ClearData

Определение:

Синтакс IDL: | VARIANT ClearData();
Синтакс Basic: | Function ClearData() As Variant
Синтакс Pascal: | function ClearData(): COleVariant;

Описание:

Учищает локальный кэш программы

Результат: True при удачном выполнении и False в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


IsValidInstance

Метод:

IAplAPI_Data::IsValidInstance

Определение:

Синтакс IDL: | VARIANT IsValidInstance(long instance);
Синтакс Basic: | Function IsValidInstance(instance As Integer) As Variant
Синтакс Pascal: | function IsValidInstance(instance: Integer): COleVariant;

Описание:

Проверяет, включен ли указанный объект базы данных в список объектов текущего класса

Результат: Возвращает True, если включен, и False в противном случае или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


LoadSystemDictionary

Метод:

IAplAPI_Data::LoadSystemDictionary

Определение:

Синтакс IDL: | VARIANT LoadSystemDictionary(BSTR schema);
Синтакс Basic: | Function LoadSystemDictionary(schema As String) As Variant
Синтакс Pascal: | function LoadSystemDictionary(schema: WideString): COleVariant;

Описание:

Читает системный словарь - файл с расширением *.dict

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | schema | имя системного словаря

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


SaveToFile

Метод:

IAplAPI_Data::SaveToFile

Определение:

Синтакс IDL: | VARIANT SaveToFile(BSTR fileName, long SaveChanges);
Синтакс Basic: | Function SaveToFile(fileName As String; SaveChanges As Integer) As Variant
Синтакс Pascal: | function SaveToFile(fileName: WideString; SaveChanges: Integer): COleVariant;

Описание:

Результат: 1 - сохранение прошо успешно. 0 - ошибка при сохранении.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | fileName | Имя файла
[in] | long | SaveChanges | Если 1 - сохраняются только изменения последней сессии. Если 0 - сохраняются все данные кэша.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


LoadFromFile

Метод:

IAplAPI_Data::LoadFromFile

Определение:

Синтакс IDL: | VARIANT LoadFromFile(BSTR fileName);
Синтакс Basic: | Function LoadFromFile(fileName As String) As Variant
Синтакс Pascal: | function LoadFromFile(fileName: WideString): COleVariant;

Описание:

Результат:

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | fileName | Имя файла

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


LoadP21

Метод:

IAplAPI_Data::LoadP21

Определение:

Синтакс IDL: | VARIANT LoadP21(BSTR fileName);
Синтакс Basic: | Function LoadP21(fileName As String) As Variant
Синтакс Pascal: | function LoadP21(fileName: WideString): COleVariant;

Описание:

Читает данные из текстового файла формата, определенного протоколом 21 стандарта STEP

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | fileName | путь к стандартному обменному файлу (если путь не задан, выводится диалог выбора файла)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


SaveP21

Метод:

IAplAPI_Data::SaveP21

Определение:

Синтакс IDL: | VARIANT SaveP21(BSTR fileName);
Синтакс Basic: | Function SaveP21(fileName As String) As Variant
Синтакс Pascal: | function SaveP21(fileName: WideString): COleVariant;

Описание:

Сохраняет данные в текстовом файле в формате, определенным протоколом 21 стандарта STEP

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | fileName | имя обменного файла

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Data


IAplAPI_Folder

Интерфейс: IAplAPI_Folder

Методы для работы с папками

GUID: {01471701-5E75-4FC3-BF4A-BAD2D548E6CA}

Методы интерфейса:

Структура папок
Содержимое папок
Прочее
Структура папок
CreateFolder | Создает новую папку
DeleteFolder | Удаляет папку
FindFolderByName | Ищет папку по наименованию
GetAllSubFolder | Возвращает вложенные папки
MoveFolder | Перемещает папку
Содержимое папок
AddToFolder | Добавляет объект в папку
GetFolderContents | Возвращает содержимое папки
RemoveFromFolder | Удаляет объект из папки
Прочее
LoadFolderInfo | Читает атрибуты папки в кэш
ShowFolderProperties | Выводит диалог со свойствами папки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


CreateFolder

Метод:

IAplAPI_Folder::CreateFolder

Определение:

Синтакс IDL: | VARIANT CreateFolder(long parentFolder, BSTR name, BSTR description);
Синтакс Basic: | Function CreateFolder(parentFolder As Integer; name As String; description As String) As Variant
Синтакс Pascal: | function CreateFolder(parentFolder: Integer; name: WideString; description: WideString): COleVariant;

Описание:

Создает в базе данных новую папку

Результат: Возвращает ссылку на созданную папку или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | parentFolder | ссылка на вышестоящую папку, в которую необходимо поместить новую или 0, если новая папка корневая
[in] | BSTR | name | наименование папки
[in] | BSTR | description | описание папки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


DeleteFolder

Метод:

IAplAPI_Folder::DeleteFolder

Определение:

Синтакс IDL: | VARIANT DeleteFolder(long folder);
Синтакс Basic: | Function DeleteFolder(folder As Integer) As Variant
Синтакс Pascal: | function DeleteFolder(folder: Integer): COleVariant;

Описание:

Удаляет папку из базы данных

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на удаляемую папку

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


FindFolderByName

Метод:

IAplAPI_Folder::FindFolderByName

Определение:

Синтакс IDL: | VARIANT FindFolderByName(BSTR name, long parentFolder);
Синтакс Basic: | Function FindFolderByName(name As String; parentFolder As Integer) As Variant
Синтакс Pascal: | function FindFolderByName(name: WideString; parentFolder: Integer): COleVariant;

Описание:

Ищет папку по наименованию.

Результат: Возвращает ссылку на найденную папку или ноль в противном случае или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | name | наименование папки
[in] | long | parentFolder | ссылка на вышестоящую папку или ноль, если ищется папка верхнего уровня (наименования папок уникально в пределах одной вышестоящей папки)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


GetAllSubFolder

Метод:

IAplAPI_Folder::GetAllSubFolder

Определение:

Синтакс IDL: | VARIANT GetAllSubFolder(long folder, VARIANT* subFolders);
Синтакс Basic: | Function GetAllSubFolder(folder As Integer; subFolders As Variant) As Variant
Синтакс Pascal: | function GetAllSubFolder(folder: Integer; out subFolders: COleVariant): COleVariant;

Описание:

Возвращает вложенные папки

Результат: Возврщает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка папку, для которой запрашиваются подпапки
[in, out] | VARIANT* | subFolders | массив, содержащий ссылки на подпапки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


MoveFolder

Метод:

IAplAPI_Folder::MoveFolder

Определение:

Синтакс IDL: | VARIANT MoveFolder(long folder, long parentFolder);
Синтакс Basic: | Function MoveFolder(folder As Integer; parentFolder As Integer) As Variant
Синтакс Pascal: | function MoveFolder(folder: Integer; parentFolder: Integer): COleVariant;

Описание:

Перемещает папку из одной вышестоящей папки в другую

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку, которая перемещается
[in] | long | parentFolder | ссылка на новую вышестоящую папку

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


AddToFolder

Метод:

IAplAPI_Folder::AddToFolder

Определение:

Синтакс IDL: | VARIANT AddToFolder(long folder, long item);
Синтакс Basic: | Function AddToFolder(folder As Integer; item As Integer) As Variant
Синтакс Pascal: | function AddToFolder(folder: Integer; item: Integer): COleVariant;

Описание:

Добавляет объект базы данных в папку

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку, в которую добавляется объект
[in] | long | item | ссылка на объект базы данных, который добавляется в папку

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


GetFolderContents

Метод:

IAplAPI_Folder::GetFolderContents

Определение:

Синтакс IDL: | VARIANT GetFolderContents(long folder, VARIANT* folderContents);
Синтакс Basic: | Function GetFolderContents(folder As Integer; folderContents As Variant) As Variant
Синтакс Pascal: | function GetFolderContents(folder: Integer; out folderContents: COleVariant): COleVariant;

Описание:

Возвращает содержимое папки

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку, содержимое которой запрашивается
[out] | VARIANT* | folderContents | массив с содержимым папки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


RemoveFromFolder

Метод:

IAplAPI_Folder::RemoveFromFolder

Определение:

Синтакс IDL: | VARIANT RemoveFromFolder(long folder, long item);
Синтакс Basic: | Function RemoveFromFolder(folder As Integer; item As Integer) As Variant
Синтакс Pascal: | function RemoveFromFolder(folder: Integer; item: Integer): COleVariant;

Описание:

Удаляет объект базы данных из папки

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку
[in] | long | item | ссылка на объект базы данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


LoadFolderInfo

Метод:

IAplAPI_Folder::LoadFolderInfo

Определение:

Синтакс IDL: | VARIANT LoadFolderInfo(long folder);
Синтакс Basic: | Function LoadFolderInfo(folder As Integer) As Variant
Синтакс Pascal: | function LoadFolderInfo(folder: Integer): COleVariant;

Описание:

Читает атрибуты папки в локальный кэш программы

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку, атрибуты которой необходимо считать или обновить

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


ShowFolderProperties

Метод:

IAplAPI_Folder::ShowFolderProperties

Определение:

Синтакс IDL: | VARIANT ShowFolderProperties(long folder);
Синтакс Basic: | Function ShowFolderProperties(folder As Integer) As Variant
Синтакс Pascal: | function ShowFolderProperties(folder: Integer): COleVariant;

Описание:

Выводит диалог со свойствами папки

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | folder | ссылка на папку

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Folder


IAplAPI_Category

Интерфейс: IAplAPI_Category

Методы для работы с категориями

GUID: {B9C4062F-3642-422C-98E9-E1501C7D108F}

Методы интерфейса:

Структура категорий
Содержимое категорий
Изменения категорий
Прочее
Структура категорий
FindCategory | Ищет категорию по обозначению
CreateCategory | Cоздает категорию
GetAllParentCategory | Возвращает родительские категории
GetAllSubCategory | Возвращает подкатегории
GetCategoryAttr | Возвращает обозначение, наименование и описание категори
InsertSubCategory | Добавляет подкатегорию
RemoveCategory | Удаляет категорию
RemoveSubCategory | Удаляет подкатегорию
RefreshRootCategories | Обновляет корневые категории
Содержимое категорий
AddProductToCategory | Добавляет изделие в категорию
RemoveProductFromCategory | Удаляет изделие из категории
GetCategoryContents | Возвращает содержимое категории
FindProductInCategory | Проверяет, находится ли изделие в категории
GetProductCategories | Возвращает категории изделия
Изменения категорий
CheckIn | Завершает редактирование категории.
CheckOut | Берет категорию на редактирование
UndoCheckOut | Отменяет редактирование категории.
GetAllCategoryVersion | Возвращает версии категории
Прочее
LoadCategoryInfo | Читает атрибуты категории в локальный кэш программы

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


FindCategory

Метод:

IAplAPI_Category::FindCategory

Определение:

Синтакс IDL: | VARIANT FindCategory(BSTR id);
Синтакс Basic: | Function FindCategory(id As String) As Variant
Синтакс Pascal: | function FindCategory(id: WideString): COleVariant;

Описание:

Ищет категорию по обозначению

Результат: Возвращает указатель на категорию в базе по ее обозначению или NULL, если такой категории нет

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение категории

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


CreateCategory

Метод:

IAplAPI_Category::CreateCategory

Определение:

Синтакс IDL: | VARIANT CreateCategory(BSTR id, BSTR name, BSTR description);
Синтакс Basic: | Function CreateCategory(id As String; name As String; description As String) As Variant
Синтакс Pascal: | function CreateCategory(id: WideString; name: WideString; description: WideString): COleVariant;

Описание:

Cоздает новую категорию в базе данных

Результат: Возвращает указательно на созданную категорию или NULL в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение категории
[in] | BSTR | name | наименование категории
[in] | BSTR | description | описание категории

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetAllParentCategory

Метод:

IAplAPI_Category::GetAllParentCategory

Определение:

Синтакс IDL: | VARIANT GetAllParentCategory(long category, VARIANT* parentCategories);
Синтакс Basic: | Function GetAllParentCategory(category As Integer; parentCategories As Variant) As Variant
Синтакс Pascal: | function GetAllParentCategory(category: Integer; out parentCategories: COleVariant): COleVariant;

Описание:

Возвращает родительские категории

Результат: True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | category | категория, для которой ищутся родители
[in, out] | VARIANT* | parentCategories | масиив родительских категорий

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetAllSubCategory

Метод:

IAplAPI_Category::GetAllSubCategory

Определение:

Синтакс IDL: | VARIANT GetAllSubCategory(long category, VARIANT* subCategories);
Синтакс Basic: | Function GetAllSubCategory(category As Integer; subCategories As Variant) As Variant
Синтакс Pascal: | function GetAllSubCategory(category: Integer; out subCategories: COleVariant): COleVariant;

Описание:

Возвращает массив входящих в категорию подкатегорий. Если категория не задана (равна нулю), возвращаются корневые категории дерева категорий

Результат: True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | category | категория, для которой запрашиваются подкатегории
[in, out] | VARIANT* | subCategories | массив подкатегорий

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetCategoryAttr

Метод:

IAplAPI_Category::GetCategoryAttr

Определение:

Синтакс IDL: | VARIANT GetCategoryAttr(long category, BSTR* id, BSTR* name, BSTR* description);
Синтакс Basic: | Function GetCategoryAttr(category As Integer; id As String; name As String; description As String) As Variant
Синтакс Pascal: | function GetCategoryAttr(category: Integer; out id: WideString; out name: WideString; out description: WideString): COleVariant;

Описание:

Возвращает обозначение, наименование и описание заданной категории категори

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | category | категория, для которой запрашивается информация
[out] | BSTR* | id | обозначение категории
[out] | BSTR* | name | наименование категории
[out] | BSTR* | description | описание категории

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


InsertSubCategory

Метод:

IAplAPI_Category::InsertSubCategory

Определение:

Синтакс IDL: | VARIANT InsertSubCategory(long baseCategory, long subCategory);
Синтакс Basic: | Function InsertSubCategory(baseCategory As Integer; subCategory As Integer) As Variant
Синтакс Pascal: | function InsertSubCategory(baseCategory: Integer; subCategory: Integer): COleVariant;

Описание:

Добавляет в категорию подкатегорию. Функция создает связь одной категории с другой, сами категории долны быть созданы ранее.

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | baseCategory | категория, в которой создается подкатегория
[in] | long | subCategory | подкатегория

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


RemoveCategory

Метод:

IAplAPI_Category::RemoveCategory

Определение:

Синтакс IDL: | VARIANT RemoveCategory(long category);
Синтакс Basic: | Function RemoveCategory(category As Integer) As Variant
Синтакс Pascal: | function RemoveCategory(category: Integer): COleVariant;

Описание:

Удаляет категорию из базы данных

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | category | категория, которую необходимо удалить

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


RemoveSubCategory

Метод:

IAplAPI_Category::RemoveSubCategory

Определение:

Синтакс IDL: | VARIANT RemoveSubCategory(long baseCategory, long subCategory);
Синтакс Basic: | Function RemoveSubCategory(baseCategory As Integer; subCategory As Integer) As Variant
Синтакс Pascal: | function RemoveSubCategory(baseCategory: Integer; subCategory: Integer): COleVariant;

Описание:

Удаляет из категории подкатегорию. Функция удаляет связь одной категории с другой, сами категории остаются в базе данных.

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | baseCategory | категория, в которой удаляется подкатегория
[in] | long | subCategory | подкатегория

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


RefreshRootCategories

Метод:

IAplAPI_Category::RefreshRootCategories

Определение:

Синтакс IDL: | VARIANT RefreshRootCategories();
Синтакс Basic: | Function RefreshRootCategories() As Variant
Синтакс Pascal: | function RefreshRootCategories(): COleVariant;

Описание:

Обновляет корневые категории

Результат: Возвращает True при удачном выполнении или False в случае ошибкт

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


AddProductToCategory

Метод:

IAplAPI_Category::AddProductToCategory

Определение:

Синтакс IDL: | VARIANT AddProductToCategory(long product, long category);
Синтакс Basic: | Function AddProductToCategory(product As Integer; category As Integer) As Variant
Синтакс Pascal: | function AddProductToCategory(product: Integer; category: Integer): COleVariant;

Описание:

Добавляет изделие в категорию. Категория должна быть заблокированна на изменение с помощью функции CheckOut.

Результат:

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | изделие, которое необходимо добавить в категорию
[in] | long | category | категория, в которую добавляется изделие

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


RemoveProductFromCategory

Метод:

IAplAPI_Category::RemoveProductFromCategory

Определение:

Синтакс IDL: | VARIANT RemoveProductFromCategory(long product, long category);
Синтакс Basic: | Function RemoveProductFromCategory(product As Integer; category As Integer) As Variant
Синтакс Pascal: | function RemoveProductFromCategory(product: Integer; category: Integer): COleVariant;

Описание:

Удаляет изделие из категории. Категория должна быть заблокированна на изменение с помощью функции CheckOut.

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | изделие, которое удаляется из категории
[in] | long | category | категория, из которой необходимо удалить изделие

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetCategoryContents

Метод:

IAplAPI_Category::GetCategoryContents

Определение:

Синтакс IDL: | VARIANT GetCategoryContents(long category, VARIANT* extent, long all);
Синтакс Basic: | Function GetCategoryContents(category As Integer; extent As Variant; all As Integer) As Variant
Синтакс Pascal: | function GetCategoryContents(category: Integer; out extent: COleVariant; all: Integer): COleVariant;

Описание:

Возвращает входящие в категорию изделия

Результат: True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | category | категория, для которой запрашивается содержимое
[in, out] | VARIANT* | extent | массив, содержащий входящие в категорию изделия
[in] | long | all | флаг, задающий режим формирования массива входящих изделий 0 - возвращается содержимое только заданной категории 1 - возвращает содержимое заданной категории и всех подкатегорий

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


FindProductInCategory

Метод:

IAplAPI_Category::FindProductInCategory

Определение:

Синтакс IDL: | VARIANT FindProductInCategory(long product, long category, long all);
Синтакс Basic: | Function FindProductInCategory(product As Integer; category As Integer; all As Integer) As Variant
Синтакс Pascal: | function FindProductInCategory(product: Integer; category: Integer; all: Integer): COleVariant;

Описание:

Проверяет, находится ли изделий в категории

Результат: Возвращает True, если изделие находится в категории или False, если изделие не удалось найти

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | указатель на изделие
[in] | long | category | указатель на категорию, в которой производится поиск изделия
[in] | long | all | флаг, задающий режим поиска: 0 - искать изделие только в заданной категории 1 - искать изделие во всех вложенных в заданную категорию подкатегориях

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetProductCategories

Метод:

IAplAPI_Category::GetProductCategories

Определение:

Синтакс IDL: | VARIANT GetProductCategories(long product, VARIANT* extent);
Синтакс Basic: | Function GetProductCategories(product As Integer; extent As Variant) As Variant
Синтакс Pascal: | function GetProductCategories(product: Integer; out extent: COleVariant): COleVariant;

Описание:

Возвращает категории, в которые входит заданное изделие

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | изделие, для которого запрашиваются категории
[in, out] | VARIANT* | extent | массив категорий, в которые входит изделие

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


CheckIn

Метод:

IAplAPI_Category::CheckIn

Определение:

Синтакс IDL: | VARIANT CheckIn(long categ);
Синтакс Basic: | Function CheckIn(categ As Integer) As Variant
Синтакс Pascal: | function CheckIn(categ: Integer): COleVariant;

Описание:

Завершает редактирование категории, при этом снимает блокировку на изменение с категории и создает в базе данных новую версию категории, если ее содержимое изменилось.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | categ | ссылка на категорию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


CheckOut

Метод:

IAplAPI_Category::CheckOut

Определение:

Синтакс IDL: | VARIANT CheckOut(long categ);
Синтакс Basic: | Function CheckOut(categ As Integer) As Variant
Синтакс Pascal: | function CheckOut(categ: Integer): COleVariant;

Описание:

Берет категорию на редактирование, при этом блокирует категорию в базе данных на изменение другими пользователями.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | categ | ссылка на категорию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


UndoCheckOut

Метод:

IAplAPI_Category::UndoCheckOut

Определение:

Синтакс IDL: | VARIANT UndoCheckOut(long categ);
Синтакс Basic: | Function UndoCheckOut(categ As Integer) As Variant
Синтакс Pascal: | function UndoCheckOut(categ: Integer): COleVariant;

Описание:

Отменяет редактирование (блокировку) категории.

Результат: Возврщает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | categ | ссылка на категорию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


GetAllCategoryVersion

Метод:

IAplAPI_Category::GetAllCategoryVersion

Определение:

Синтакс IDL: | VARIANT GetAllCategoryVersion(long categ, VARIANT* versions);
Синтакс Basic: | Function GetAllCategoryVersion(categ As Integer; versions As Variant) As Variant
Синтакс Pascal: | function GetAllCategoryVersion(categ: Integer; out versions: COleVariant): COleVariant;

Описание:

Возвращает версии категории

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | categ | категория, для которой запрашиваются версии
[out] | VARIANT* | versions | массив версий

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


LoadCategoryInfo

Метод:

IAplAPI_Category::LoadCategoryInfo

Определение:

Синтакс IDL: | VARIANT LoadCategoryInfo(long categ);
Синтакс Basic: | Function LoadCategoryInfo(categ As Integer) As Variant
Синтакс Pascal: | function LoadCategoryInfo(categ: Integer): COleVariant;

Описание:

Читает атрибуты категории в локальный кэш программы

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | categ | категория, для которой необходимо загрузить информацию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Category


IAplAPI_Document

Интерфейс: IAplAPI_Document

Методы для работы с документами

GUID: {4B7D707D-470A-4C1B-8D98-21B49761FCBB}

Методы интерфейса:

Работа со словарем
Поиск
Создание / Удаление
Просмотр / Изменение
Связь с другими объектами
Прочее
Работа со словарем
LoadDocumentDictionary | Читает словарные данные
Поиск
FindDocById | Ищет документ по обозначению
GetDocumentTypeBN | Ищет тип документа по наименованию
Создание / Удаление
CreateDocument | Создает новый документ
CreateFile | Создает файл
DeleteDoc | Удаляет документ
DeleteRevision | Удаляет версию документа
Просмотр / Изменение
CheckIn | Завершает редактирование документа
CheckOut | Берет документ на редактирование
UndoCheckOut | Отменяет редактирование (блокировку) документа
LoadRevision | Копирует доступный только для чтения файл документа на жесткий диск
View | Берет документ на просмотр и запускает соответствующее приложение
Edit | Берет документ на редактирование и запускает соответствующее приложение
CreateDocumentRevision | Создает новую версию документа
ShowDocChanges | Выводит диалог с историей изменений документа
LoadAllDocumentRevision | Возвращает версии документа
Связь с другими объектами
CreateAssociation | Создает связь между объектом и документом
FindAssociatedDocuments | Возвращает связанные с объектом документы
FindAssociation | Ищет связь между объектом и документом
Прочее
LoadDocInfo | Читает атрибуты документа в кэш
GetFileName | Возвращает имя файла
GetFullFileName | Возвращает полное (с путем) имя файла
SelectDocType | Выводит диалог для выбора типа документа
ShowDocumentProperties | Выводит диалог со свойствами документа
CheckSubDocument | Проверяет наличие у документа связанных документов

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


LoadDocumentDictionary

Метод:

IAplAPI_Document::LoadDocumentDictionary

Определение:

Синтакс IDL: | VARIANT LoadDocumentDictionary();
Синтакс Basic: | Function LoadDocumentDictionary() As Variant
Синтакс Pascal: | function LoadDocumentDictionary(): COleVariant;

Описание:

Читает словарные данные (типы документов), относящиеся к документам.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


FindDocById

Метод:

IAplAPI_Document::FindDocById

Определение:

Синтакс IDL: | VARIANT FindDocById(BSTR id);
Синтакс Basic: | Function FindDocById(id As String) As Variant
Синтакс Pascal: | function FindDocById(id: WideString): COleVariant;

Описание:

Ищет в базе данных документ по его обозначению.

Результат: Возвращает ссылку на найденный документ или ноль, если документ не найден или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


GetDocumentTypeBN

Метод:

IAplAPI_Document::GetDocumentTypeBN

Определение:

Синтакс IDL: | VARIANT GetDocumentTypeBN(BSTR type);
Синтакс Basic: | Function GetDocumentTypeBN(type As String) As Variant
Синтакс Pascal: | function GetDocumentTypeBN(type: WideString): COleVariant;

Описание:

Ищет в базе данных тип документа по его наименованию.

Результат: Возвращает ссылку на тип документа или ноль, если тип не найден или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | type | наименование типа документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CreateDocument

Метод:

IAplAPI_Document::CreateDocument

Определение:

Синтакс IDL: | VARIANT CreateDocument(BSTR id, BSTR name, BSTR description, long type, BSTR path, long stored);
Синтакс Basic: | Function CreateDocument(id As String; name As String; description As String; type As Integer; path As String; stored As Integer) As Variant
Синтакс Pascal: | function CreateDocument(id: WideString; name: WideString; description: WideString; type: Integer; path: WideString; stored: Integer): COleVariant;

Описание:

Создает в базе данных новый документ (если не задано или обозначение, или наименование, или путь к файлу документа, выволится диалог для уточнения этих параметров).

Результат: Возвращает ссылку на вновь созданный документ или ноль в случае ошибки или отмены операции.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение документа
[in] | BSTR | name | наименование документа
[in] | BSTR | description | описание документа
[in] | long | type | ссылка на тип документа
[in] | BSTR | path | путь на жестком диске к файлу документа
[in] | long | stored | флаг, задающий режим работы функции: 0 - не сохранять тело документа (файл) в базе данных (сохраняется только путь к файлу) 1 - сохранять тело документа в базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CreateFile

Метод:

IAplAPI_Document::CreateFile

Определение:

Синтакс IDL: | VARIANT CreateFile(BSTR path, long stored);
Синтакс Basic: | Function CreateFile(path As String; stored As Integer) As Variant
Синтакс Pascal: | function CreateFile(path: WideString; stored: Integer): COleVariant;

Описание:

Создает в базе данных объект, описывающий файл документа.

Результат: Возвращает ссылку на созданный файл или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | path | путь на жестком диске, по которому находится файл
[in] | long | stored | флаг, задающий режим работы функции: 0 - не сохранять тело файла в базе данных (сохраняется только путь к файлу) 1 - сохранять тело файла в базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


DeleteDoc

Метод:

IAplAPI_Document::DeleteDoc

Определение:

Синтакс IDL: | VARIANT DeleteDoc(long doc);
Синтакс Basic: | Function DeleteDoc(doc As Integer) As Variant
Синтакс Pascal: | function DeleteDoc(doc: Integer): COleVariant;

Описание:

Удаляет из базы данных документ.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | doc | ссылка на документ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


DeleteRevision

Метод:

IAplAPI_Document::DeleteRevision

Определение:

Синтакс IDL: | VARIANT DeleteRevision(long revision);
Синтакс Basic: | Function DeleteRevision(revision As Integer) As Variant
Синтакс Pascal: | function DeleteRevision(revision: Integer): COleVariant;

Описание:

Удаляет версию документа из базы данных (удаляемая версия не должна быть текущей активной).

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | revision | ссылка на версию документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CheckIn

Метод:

IAplAPI_Document::CheckIn

Определение:

Синтакс IDL: | VARIANT CheckIn(long doc, BSTR path, long setActive);
Синтакс Basic: | Function CheckIn(doc As Integer; path As String; setActive As Integer) As Variant
Синтакс Pascal: | function CheckIn(doc: Integer; path: WideString; setActive: Integer): COleVariant;

Описание:

Завершает редактирование документа, при этом снимает блокировку на изменение с документа и создает в базе данных новую версию документа, если файл изменился.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | doc | ссылка на документ, редактирование которого завершается
[in] | BSTR | path | путь на жестком диске, где находится отредактированный файл документа
[in] | long | setActive | флаг, задающий режим работы функции: 0 - не делать новую версию активной 1 - сделать новую версию активной

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CheckOut

Метод:

IAplAPI_Document::CheckOut

Определение:

Синтакс IDL: | VARIANT CheckOut(long docOrRevision, BSTR path);
Синтакс Basic: | Function CheckOut(docOrRevision As Integer; path As String) As Variant
Синтакс Pascal: | function CheckOut(docOrRevision: Integer; path: WideString): COleVariant;

Описание:

Берет документ на редактирование, при этом блокирует документ в базе данных на изменение другими пользователями и создает на жестком диске файл документа, доступный для изменения.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа, который блокируется
[in] | BSTR | path | путь к файлу на жестком диске, по которому будет скопирован файл документа для редактирования

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


UndoCheckOut

Метод:

IAplAPI_Document::UndoCheckOut

Определение:

Синтакс IDL: | VARIANT UndoCheckOut(long docOrRevision);
Синтакс Basic: | Function UndoCheckOut(docOrRevision As Integer) As Variant
Синтакс Pascal: | function UndoCheckOut(docOrRevision: Integer): COleVariant;

Описание:

Отменяет редактирование (блокировку) документа

Результат: Возврщает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


LoadRevision

Метод:

IAplAPI_Document::LoadRevision

Определение:

Синтакс IDL: | VARIANT LoadRevision(long docOrRevision, BSTR path);
Синтакс Basic: | Function LoadRevision(docOrRevision As Integer; path As String) As Variant
Синтакс Pascal: | function LoadRevision(docOrRevision: Integer; path: WideString): COleVariant;

Описание:

Копирует доступный только для чтения файл документа или версии документа на жесткий диск

Результат: Возврщает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа
[in] | BSTR | path | путь к файлу на жестком диске: если указан файл, то пишется в этот файл если указан каталог (последний символ '\'), имя файла берется по умолчанию если указана пустая строка, путь запрашивается

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


View

Метод:

IAplAPI_Document::View

Определение:

Синтакс IDL: | VARIANT View(long docOrRevision);
Синтакс Basic: | Function View(docOrRevision As Integer) As Variant
Синтакс Pascal: | function View(docOrRevision: Integer): COleVariant;

Описание:

Копирует документ из базы данных на жесткий диск и открывает сооветсвующее приложение для просмотра. После завершения копия документа удаляется с диска.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


Edit

Метод:

IAplAPI_Document::Edit

Определение:

Синтакс IDL: | VARIANT Edit(long docOrRevision);
Синтакс Basic: | Function Edit(docOrRevision As Integer) As Variant
Синтакс Pascal: | function Edit(docOrRevision: Integer): COleVariant;

Описание:

Берет документ на редактирование и запускает соответствующее приложение.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CreateDocumentRevision

Метод:

IAplAPI_Document::CreateDocumentRevision

Определение:

Синтакс IDL: | VARIANT CreateDocumentRevision(long document, BSTR path, long stored, long setActive, long baseRevision);
Синтакс Basic: | Function CreateDocumentRevision(document As Integer; path As String; stored As Integer; setActive As Integer; baseRevision As Integer) As Variant
Синтакс Pascal: | function CreateDocumentRevision(document: Integer; path: WideString; stored: Integer; setActive: Integer; baseRevision: Integer): COleVariant;

Описание:

Создает в базе данных новую версию документа.

Результат: Возвращает ссылку на вновь созданную версию документа или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | document | ссылка на документ
[in] | BSTR | path | путь на жестком диске, по которому находится файл документа
[in] | long | stored | флаг, задающий режим работы функции: 0 - не сохранять тело документа (файл) в базе данных (сохраняется только путь к файлу) 1 - сохранять тело документа в базе данных
[in] | long | setActive | флаг, задающий режим работы функции: 0 - не делать новую версию активной 1 - сделать новую версию активной
[in] | long | baseRevision | ссылка на версию документа, на основе которой создается новая версия (если параметр равен нулю, версия создается на основе текущей активной)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


ShowDocChanges

Метод:

IAplAPI_Document::ShowDocChanges

Определение:

Синтакс IDL: | VARIANT ShowDocChanges(long document);
Синтакс Basic: | Function ShowDocChanges(document As Integer) As Variant
Синтакс Pascal: | function ShowDocChanges(document: Integer): COleVariant;

Описание:

Выводит диалог с историей изменений документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | document | ссылка на документ. история которого запрашивается

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


LoadAllDocumentRevision

Метод:

IAplAPI_Document::LoadAllDocumentRevision

Определение:

Синтакс IDL: | VARIANT LoadAllDocumentRevision(long doc, VARIANT* revExt);
Синтакс Basic: | Function LoadAllDocumentRevision(doc As Integer; revExt As Variant) As Variant
Синтакс Pascal: | function LoadAllDocumentRevision(doc: Integer; out revExt: COleVariant): COleVariant;

Описание:

Возвращает версии документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | doc | ссылка на документ
[in, out] | VARIANT* | revExt | массив, содержащий ссылки на версии документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CreateAssociation

Метод:

IAplAPI_Document::CreateAssociation

Определение:

Синтакс IDL: | VARIANT CreateAssociation(long instance, long doc);
Синтакс Basic: | Function CreateAssociation(instance As Integer; doc As Integer) As Variant
Синтакс Pascal: | function CreateAssociation(instance: Integer; doc: Integer): COleVariant;

Описание:

Создает связь между объектом базы данных и документом.

Результат: Возвращает ссылку на связь между объектом и документом или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных
[in] | long | doc | ссылка на документ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


FindAssociatedDocuments

Метод:

IAplAPI_Document::FindAssociatedDocuments

Определение:

Синтакс IDL: | VARIANT FindAssociatedDocuments(long instance, VARIANT* outExt, VARIANT* outRel);
Синтакс Basic: | Function FindAssociatedDocuments(instance As Integer; outExt As Variant; outRel As Variant) As Variant
Синтакс Pascal: | function FindAssociatedDocuments(instance: Integer; out outExt: COleVariant; out outRel: COleVariant): COleVariant;

Описание:

Возвращает связанные с объектом базы данных документы

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных
[in, out] | VARIANT* | outExt | массив, содержащий ссылки на документы
[in, out] | VARIANT* | outRel | массив, содержащий ссылки на объекты, описывающие связь между объектом базы данных и документом

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


FindAssociation

Метод:

IAplAPI_Document::FindAssociation

Определение:

Синтакс IDL: | VARIANT FindAssociation(long instance, long doc);
Синтакс Basic: | Function FindAssociation(instance As Integer; doc As Integer) As Variant
Синтакс Pascal: | function FindAssociation(instance: Integer; doc: Integer): COleVariant;

Описание:

Ищет связь между объектом базы данных и документом

Результат: Возвращает ссылку на связь между объектом и документом или ноль, если связь не найдена или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных
[in] | long | doc | ссылка на документ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


LoadDocInfo

Метод:

IAplAPI_Document::LoadDocInfo

Определение:

Синтакс IDL: | VARIANT LoadDocInfo(long doc);
Синтакс Basic: | Function LoadDocInfo(doc As Integer) As Variant
Синтакс Pascal: | function LoadDocInfo(doc: Integer): COleVariant;

Описание:

Читает атрибуты документа в локальный кэш программы.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | doc | ссылка на документ, атрибуты которого читаются или обновляются

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


GetFileName

Метод:

IAplAPI_Document::GetFileName

Определение:

Синтакс IDL: | VARIANT GetFileName(long docOrRevision, BSTR buf);
Синтакс Basic: | Function GetFileName(docOrRevision As Integer; buf As String) As Variant
Синтакс Pascal: | function GetFileName(docOrRevision: Integer; buf: WideString): COleVariant;

Описание:

Возвращает имя файла документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа
[in] | BSTR | buf | строка, содержащая имя файла документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


GetFullFileName

Метод:

IAplAPI_Document::GetFullFileName

Определение:

Синтакс IDL: | VARIANT GetFullFileName(long docOrRevision, BSTR buf);
Синтакс Basic: | Function GetFullFileName(docOrRevision As Integer; buf As String) As Variant
Синтакс Pascal: | function GetFullFileName(docOrRevision: Integer; buf: WideString): COleVariant;

Описание:

Возвращает полное (с путем) имя файла документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа
[in] | BSTR | buf | строка, содержащая имя файла документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


SelectDocType

Метод:

IAplAPI_Document::SelectDocType

Определение:

Синтакс IDL: | VARIANT SelectDocType(long selectedDocType, long selectedDocGroup);
Синтакс Basic: | Function SelectDocType(selectedDocType As Integer; selectedDocGroup As Integer) As Variant
Синтакс Pascal: | function SelectDocType(selectedDocType: Integer; selectedDocGroup: Integer): COleVariant;

Описание:

Выводит диалог для выбора типа документа.

Результат: Возвращает выбранный тип документа или ноль в случае ошибки или отмены операции.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | selectedDocType | ссылка на тип документа, котораый будет выделен в диалоге выбора по умолчанию
[in] | long | selectedDocGroup | ссылка на объединение типов документов, которое будет выведена в диалоге выбора по умолчанию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


ShowDocumentProperties

Метод:

IAplAPI_Document::ShowDocumentProperties

Определение:

Синтакс IDL: | VARIANT ShowDocumentProperties(long docOrRevision);
Синтакс Basic: | Function ShowDocumentProperties(docOrRevision As Integer) As Variant
Синтакс Pascal: | function ShowDocumentProperties(docOrRevision: Integer): COleVariant;

Описание:

Выводит диалог для просмотра или редактирования свойств документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


CheckSubDocument

Метод:

IAplAPI_Document::CheckSubDocument

Определение:

Синтакс IDL: | VARIANT CheckSubDocument(long docOrRevision);
Синтакс Basic: | Function CheckSubDocument(docOrRevision As Integer) As Variant
Синтакс Pascal: | function CheckSubDocument(docOrRevision: Integer): COleVariant;

Описание:

Проверяет наличие у документа или версии документа связанных документов.

Результат: Возвращает True при наличии связанных документов или False при отсутствии таковых или в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | docOrRevision | ссылка на документ или версию документа, у которого проверяется наличие связанных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Document


IAplAPI_Product

Интерфейс: IAplAPI_Product

Методы для работы с изделиями

GUID: {7D805BEC-19BE-4C1D-9AED-68A1292DFF9A}

Методы интерфейса:

Создание
Чтение данных (структуры и т.д.)
Поиск
Преобразование строк (тип и покупное)
Создание
CreatePDF | Создает изделие и версию изделия
CreatePdfRelation | Создает связь между изделиями 'входит в состав'
Чтение данных (структуры и т.д.)
LoadProductInfo | Читает атрибуты изделия в кэш
GetAllProductVersion | Возвращает версии изделия
LoadAllSubProduct | Возвращает одноуровневый состав изделия
FilterlByDate | Фильтрует массив связей по дате
FilterlBySN | Фильтрует массив связей по серийному номеру
WhereProductUsed | Возвращает список сборок, в которые данная версия изделия входит
DisassemblyProduct | Возвращает полный или подетальный состав изделия
LoadAllZagotov | Возвращает заготовки и материалы изделия
LoadProductAlternates | Возвращает аналоги изделия
Поиск
FindPdfByID | Ищет версию изделия по обозначению
FindProductByID | Ищет изделие по обозначению
Преобразование строк (тип и покупное)
StrConvertPdfType2Rus | Преобразует наименование типа изделия из английского в русский
StrConvertRus2PdfType | Преобразует наименование типа изделия из русского в английский
StrConvertMakeOrBuy2Rus | Преобразует наименование источника из английского в русский
StrConvertRus2MakeOrBuy | Преобразует наименование источника из русского в английский

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


CreatePDF

Метод:

IAplAPI_Product::CreatePDF

Определение:

Синтакс IDL: | VARIANT CreatePDF(BSTR id, BSTR name, BSTR version, long testUnique);
Синтакс Basic: | Function CreatePDF(id As String; name As String; version As String; testUnique As Integer) As Variant
Синтакс Pascal: | function CreatePDF(id: WideString; name: WideString; version: WideString; testUnique: Integer): COleVariant;

Описание:

Создает новое изделие и версию изделия в базе данных

Результат: Возвращает указатель на версию изделия или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение изделия
[in] | BSTR | name | наименование изделия
[in] | BSTR | version | обозначение версии изделия
[in] | long | testUnique | флаг, устанавливающий режим работы функции: 0 - проверка уникальности обозначения изделия и версии изделия не производится 1 - производится проверка уникальности: если изделие с обозначением id в базе данных уже существует, новое не создается, если у изделия с обозначением id уже существует версия с обозначением version, новая версия не создается

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


CreatePdfRelation

Метод:

IAplAPI_Product::CreatePdfRelation

Определение:

Синтакс IDL: | VARIANT CreatePdfRelation(long context, long relatingPDF, long relatedPDF, BSTR id, BSTR name, double count, long unit);
Синтакс Basic: | Function CreatePdfRelation(context As Integer; relatingPDF As Integer; relatedPDF As Integer; id As String; name As String; count As Double; unit As Integer) As Variant
Синтакс Pascal: | function CreatePdfRelation(context: Integer; relatingPDF: Integer; relatedPDF: Integer; id: WideString; name: WideString; count: Double; unit: Integer): COleVariant;

Описание:

Создает связь между двумя версиями изделия 'входит в состав'

Результат: Возвращает ссылку на вновь созданную связь 'входит в состав' или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | context | ссылка на контекст связи или 0, если входящее изделие будет актуально во всех контекстах
[in] | long | relatingPDF | ссылка на изделие, в состав которого включается другое изделие
[in] | long | relatedPDF | ссылка на изделие, которое включается в состав другого
[in] | BSTR | id | обозначение связи (используется для сохранения позиции)
[in] | BSTR | name | наименование связи (не используется)
[in] | double | count | количество, в котором входящее изделие включается в состав вышестоящего
[in] | long | unit | ссылка на единицу измерения количества

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


LoadProductInfo

Метод:

IAplAPI_Product::LoadProductInfo

Определение:

Синтакс IDL: | VARIANT LoadProductInfo(long instance);
Синтакс Basic: | Function LoadProductInfo(instance As Integer) As Variant
Синтакс Pascal: | function LoadProductInfo(instance: Integer): COleVariant;

Описание:

Читает атрибуты изделия или версии изделия в локальный кэш программы

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на изделие или версию изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


GetAllProductVersion

Метод:

IAplAPI_Product::GetAllProductVersion

Определение:

Синтакс IDL: | VARIANT GetAllProductVersion(long prd, VARIANT* outExt);
Синтакс Basic: | Function GetAllProductVersion(prd As Integer; outExt As Variant) As Variant
Синтакс Pascal: | function GetAllProductVersion(prd: Integer; out outExt: COleVariant): COleVariant;

Описание:

Производит поиск и возвращает версии переданного изделия

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | prd | ссылка на изделия, версии которого запрашиваются
[in, out] | VARIANT* | outExt | массив, содержащий версии изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


LoadAllSubProduct

Метод:

IAplAPI_Product::LoadAllSubProduct

Определение:

Синтакс IDL: | VARIANT LoadAllSubProduct(long ci, long context, long pdf, VARIANT* extRel, VARIANT* extPdf, long fromBase);
Синтакс Basic: | Function LoadAllSubProduct(ci As Integer; context As Integer; pdf As Integer; extRel As Variant; extPdf As Variant; fromBase As Integer) As Variant
Синтакс Pascal: | function LoadAllSubProduct(ci: Integer; context: Integer; pdf: Integer; out extRel: COleVariant; out extPdf: COleVariant; fromBase: Integer): COleVariant;

Описание:

Возвращает одноуровневый состав (спецификацию) изделия

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | ci | параметр зарезервирован и не используется
[in] | long | context | ссылка на контекст, ограничивающий состав изделия или 0, если контекст не надо учитывать
[in] | long | pdf | ссылка на версию изделия, состав которой запрашивается
[out] | VARIANT* | extRel | массив связей 'входит в состав'
[out] | VARIANT* | extPdf | массив входящих изделий, содержит ссылки на версии изделия
[in] | long | fromBase | флаг, задающий режим работы функции: 0 - связи ищутся в локальном кэше программы 1 - связи ищутся по всей базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


FilterlByDate

Метод:

IAplAPI_Product::FilterlByDate

Определение:

Синтакс IDL: | VARIANT FilterlByDate(VARIANT inExt, DATE time, VARIANT* outExt);
Синтакс Basic: | Function FilterlByDate(inExt As Variant; time As Date; outExt As Variant) As Variant
Синтакс Pascal: | function FilterlByDate(inExt: COleVariant; time: TDateTime; out outExt: COleVariant): COleVariant;

Описание:

Фильтрует массив связей по дате в соответствии с правилами применяемости, наложенными на связи

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | VARIANT | inExt | входной массив связей между версиями изделия, который необходимо отфильтровать
[in] | DATE | time | дата, на которую фильтруются связи
[out] | VARIANT* | outExt | массив, содержащий результаты фильтрации

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


FilterlBySN

Метод:

IAplAPI_Product::FilterlBySN

Определение:

Синтакс IDL: | VARIANT FilterlBySN(VARIANT inExt, BSTR sn, VARIANT* outExt);
Синтакс Basic: | Function FilterlBySN(inExt As Variant; sn As String; outExt As Variant) As Variant
Синтакс Pascal: | function FilterlBySN(inExt: COleVariant; sn: WideString; out outExt: COleVariant): COleVariant;

Описание:

Фильтрует массив связей по серийному номеру в соответствии с правилами применяемости, наложенными на связи

Результат:

Параметры метода:

Специф. | Тип | Название | Описание
[in] | VARIANT | inExt | входной массив связей между версиями изделия, который необходимо отфильтровать
[in] | BSTR | sn | серийный номер
[out] | VARIANT* | outExt | массив, содержащий результаты фильтрации

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


WhereProductUsed

Метод:

IAplAPI_Product::WhereProductUsed

Определение:

Синтакс IDL: | VARIANT WhereProductUsed(long pdf, VARIANT* extRel, VARIANT* extPdf, long fromBase);
Синтакс Basic: | Function WhereProductUsed(pdf As Integer; extRel As Variant; extPdf As Variant; fromBase As Integer) As Variant
Синтакс Pascal: | function WhereProductUsed(pdf: Integer; out extRel: COleVariant; out extPdf: COleVariant; fromBase: Integer): COleVariant;

Описание:

Возвращает список сборок, в которые данная версия изделия входит

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | pdf | версия изделия
[out] | VARIANT* | extRel | массив, в котором возвращаются сборки
[out] | VARIANT* | extPdf | массив, в котором возвращаются найденные связи 'входит в состав'
[in] | long | fromBase | флаг, задающий режим работы функции: 0 - связи ищутся в локальном кэше программы 1 - связи ищутся по всей базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


DisassemblyProduct

Метод:

IAplAPI_Product::DisassemblyProduct

Определение:

Синтакс IDL: | VARIANT DisassemblyProduct(long ci, long context, long pdf, VARIANT* pdfArray, VARIANT* countArray, VARIANT* unitArray, long ReturnOnlyPart);
Синтакс Basic: | Function DisassemblyProduct(ci As Integer; context As Integer; pdf As Integer; pdfArray As Variant; countArray As Variant; unitArray As Variant; ReturnOnlyPart As Integer) As Variant
Синтакс Pascal: | function DisassemblyProduct(ci: Integer; context: Integer; pdf: Integer; out pdfArray: COleVariant; out countArray: COleVariant; out unitArray: COleVariant; ReturnOnlyPart: Integer): COleVariant;

Описание:

Возвращает полный (с промежуточными сборками) или подетальный (учитываются детали и материалы на всех уровнях) состав изделия

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | ci | параметр зарезервирован и не используется
[in] | long | context | ссылка на контекст, ограничивающий состав изделия или 0, если контекст не надо учитывать
[in] | long | pdf | версия изделия, состав которой запрашивается
[out] | VARIANT* | pdfArray | массив входящих изделий, содержит версии изделия
[out] | VARIANT* | countArray | массив содержащий общее количество версий изделий в сборке
[out] | VARIANT* | unitArray | массив, содержащий единицы измерения количества
[in] | long | ReturnOnlyPart | флаг, задающий режим формирования выходных массивов: 0 - в результат необходимо включать промежуточные сборки 1 - в результате будут только детали и материалы

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


LoadAllZagotov

Метод:

IAplAPI_Product::LoadAllZagotov

Определение:

Синтакс IDL: | VARIANT LoadAllZagotov(long pdf, VARIANT* extRel, VARIANT* extPdf, long includeDesign, long fromBase);
Синтакс Basic: | Function LoadAllZagotov(pdf As Integer; extRel As Variant; extPdf As Variant; includeDesign As Integer; fromBase As Integer) As Variant
Синтакс Pascal: | function LoadAllZagotov(pdf: Integer; out extRel: COleVariant; out extPdf: COleVariant; includeDesign: Integer; fromBase: Integer): COleVariant;

Описание:

Возвращает заготовки и материалы, из которых может быть изготовлено изделия.

Результат:

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | pdf | версия изделия, для которого запрашиваются материалы и заготовки
[out] | VARIANT* | extRel | массив связей, описывающий взаимосвязь 'изготавливается из'
[out] | VARIANT* | extPdf | массив заготовок и материалов, содержит версии изделия
[in] | long | includeDesign | флаг, задающий режим формирования массивов: 0 - не учитывать связи с типом design_make_from_relationship 1 - учитывать связи с типом design_make_from_relationship
[in] | long | fromBase | флаг, задающий режим работы функции: 0 - связи ищутся в локальном кэше программы 1 - связи ищутся по всей базе данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


LoadProductAlternates

Метод:

IAplAPI_Product::LoadProductAlternates

Определение:

Синтакс IDL: | VARIANT LoadProductAlternates(long product, VARIANT* extRel, VARIANT* extPrd);
Синтакс Basic: | Function LoadProductAlternates(product As Integer; extRel As Variant; extPrd As Variant) As Variant
Синтакс Pascal: | function LoadProductAlternates(product: Integer; out extRel: COleVariant; out extPrd: COleVariant): COleVariant;

Описание:

Возвращает аналоги изделия

Результат: Возврашает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | ссылка на изделие, аналоги которого запрашиваются
[out] | VARIANT* | extRel | массив связей, описывающих аналоги изделия
[out] | VARIANT* | extPrd | массив аналогов, содержит ссылки на изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


FindPdfByID

Метод:

IAplAPI_Product::FindPdfByID

Определение:

Синтакс IDL: | VARIANT FindPdfByID(long product, BSTR id);
Синтакс Basic: | Function FindPdfByID(product As Integer; id As String) As Variant
Синтакс Pascal: | function FindPdfByID(product: Integer; id: WideString): COleVariant;

Описание:

Ищет версию изделия в базе данных по его обозначению

Результат: Ссылку на найденную версию изделия или 0, если версия не найдена

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | product | ссылка на версию изделия, версия которого ищется
[in] | BSTR | id | обозначение версии изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


FindProductByID

Метод:

IAplAPI_Product::FindProductByID

Определение:

Синтакс IDL: | VARIANT FindProductByID(BSTR id);
Синтакс Basic: | Function FindProductByID(id As String) As Variant
Синтакс Pascal: | function FindProductByID(id: WideString): COleVariant;

Описание:

Ищет изделие в базе данных по его обозначению

Результат: Ссылку на найденное изделие или 0, если изделие не найдено

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


StrConvertPdfType2Rus

Метод:

IAplAPI_Product::StrConvertPdfType2Rus

Определение:

Синтакс IDL: | VARIANT StrConvertPdfType2Rus(BSTR sType);
Синтакс Basic: | Function StrConvertPdfType2Rus(sType As String) As Variant
Синтакс Pascal: | function StrConvertPdfType2Rus(sType: WideString): COleVariant;

Описание:

Преобразует английское наименование типа изделия, хранящегося в базе данных, в русское.

Результат: Возвращает русское наименование типа изделия.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | sType | английское наименование типа изделия

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


StrConvertRus2PdfType

Метод:

IAplAPI_Product::StrConvertRus2PdfType

Определение:

Синтакс IDL: | VARIANT StrConvertRus2PdfType(BSTR sRusType);
Синтакс Basic: | Function StrConvertRus2PdfType(sRusType As String) As Variant
Синтакс Pascal: | function StrConvertRus2PdfType(sRusType: WideString): COleVariant;

Описание:

Преобразует русское наименование типа изделия в английское, для записи в базу данных.

Результат: Возвращает английское наименование типа изделия.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | sRusType | русское наименование типа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


StrConvertMakeOrBuy2Rus

Метод:

IAplAPI_Product::StrConvertMakeOrBuy2Rus

Определение:

Синтакс IDL: | VARIANT StrConvertMakeOrBuy2Rus(BSTR sSource);
Синтакс Basic: | Function StrConvertMakeOrBuy2Rus(sSource As String) As Variant
Синтакс Pascal: | function StrConvertMakeOrBuy2Rus(sSource: WideString): COleVariant;

Описание:

Преобразует наименование источника из английского, хранящегося в базе данных, в русский

Результат: Возвращает русское наименование источника.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | sSource | английское наименование источника

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


StrConvertRus2MakeOrBuy

Метод:

IAplAPI_Product::StrConvertRus2MakeOrBuy

Определение:

Синтакс IDL: | VARIANT StrConvertRus2MakeOrBuy(BSTR sRusSource);
Синтакс Basic: | Function StrConvertRus2MakeOrBuy(sRusSource As String) As Variant
Синтакс Pascal: | function StrConvertRus2MakeOrBuy(sRusSource: WideString): COleVariant;

Описание:

Преобразует наименование источника изделия из русского в английский для записи значения в базу данных.

Результат: Возвращает английское наименование источника.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | sRusSource | русское наименование источника

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Product


IAplAPI_Autorization

Интерфейс: IAplAPI_Autorization

Методы для работы с организационной структурой

GUID: {1DECE202-C8D4-453E-9B48-DBE7B9FCAEC0}

Методы интерфейса:

Оргструктура
Статусы
ЭЦП
Абоненты
Оргструктура
LoadOrgStruct | Читает словарные данные
GetCurrentPerson | Возвращает ссылку на сотрудника
GetPersonName | Возвращает наименование элемента организационной структуры
SelectPersonOrOrganization | Выводит диалог для выбора сотрудника или организации
SelectPersonsOrganizations | Выводит диалог для выбора нескольких сотрудников и/или организаций
Статусы
CreateApproval | Присваивает статус объекту
LoadItemApproval | Возвращает статусы объектов
ShowApproval | Выводит диалог со свойствами статуса
CreateApprovalEx | Создает статус объекта (без вывода диалога)
ЭЦП
SignDocument | Создает ЭЦП документа
CheckApproval | Проверяет ЭЦП документа
Абоненты
GetPersonOfficials | Возвращает абонентов сотрудника
ShowOfficialHistory | Выводит диалог с историей абонента
ShowPersonOfficials | Выводит диалог с абонентами сотрудника

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


LoadOrgStruct

Метод:

IAplAPI_Autorization::LoadOrgStruct

Определение:

Синтакс IDL: | VARIANT LoadOrgStruct();
Синтакс Basic: | Function LoadOrgStruct() As Variant
Синтакс Pascal: | function LoadOrgStruct(): COleVariant;

Описание:

Читает словарные данные, относящиеся к организационной структуре

Результат: Возаращает True при удачном выполнении или False в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


GetCurrentPerson

Метод:

IAplAPI_Autorization::GetCurrentPerson

Определение:

Синтакс IDL: | VARIANT GetCurrentPerson();
Синтакс Basic: | Function GetCurrentPerson() As Variant
Синтакс Pascal: | function GetCurrentPerson(): COleVariant;

Описание:

Возвращает ссылку на сотрудника, ассоциированного с текущим пользователем

Результат: ссылка на сотрудника при удачном выполнении и NULL в случае ошибки или в случае, когда с пользователем не связан сотрудник

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


GetPersonName

Метод:

IAplAPI_Autorization::GetPersonName

Определение:

Синтакс IDL: | VARIANT GetPersonName(long personOrOrg);
Синтакс Basic: | Function GetPersonName(personOrOrg As Integer) As Variant
Синтакс Pascal: | function GetPersonName(personOrOrg: Integer): COleVariant;

Описание:

Возвращает наименование элемента организационной структуры (сотрудников, организаций или абонента) в соответствии с глобальными настройками имен объектов

Результат: Возвращает наименование объекта или пустую строку в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | personOrOrg | указатель на сотрудника, организацию или абонента

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


SelectPersonOrOrganization

Метод:

IAplAPI_Autorization::SelectPersonOrOrganization

Определение:

Синтакс IDL: | VARIANT SelectPersonOrOrganization(long mode, BSTR sDialogTitle, BSTR sTreeTitle);
Синтакс Basic: | Function SelectPersonOrOrganization(mode As Integer; sDialogTitle As String; sTreeTitle As String) As Variant
Синтакс Pascal: | function SelectPersonOrOrganization(mode: Integer; sDialogTitle: WideString; sTreeTitle: WideString): COleVariant;

Описание:

Выводит диалог для выбора сотрудника или организации

Результат: Возвращает выбранного сотрудника или организации или ноль в случае ошибки или отмены операции

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | mode | значение, которое задает режим выбора объекта организационной структуры (можно выбирать сотрудника, абонента, сотрудника определенной организации и организацию, подробнее см. описание SelectInstance)
[in] | BSTR | sDialogTitle | заголовок диалога
[in] | BSTR | sTreeTitle | заголовок дерева объектов организационной структуры

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


SelectPersonsOrganizations

Метод:

IAplAPI_Autorization::SelectPersonsOrganizations

Определение:

Синтакс IDL: | VARIANT SelectPersonsOrganizations(long mode, BSTR sDialogTitle, BSTR sTreeTitle, VARIANT* persOrOrgs, long bShowUserWG, long bRecursiveSelect);
Синтакс Basic: | Function SelectPersonsOrganizations(mode As Integer; sDialogTitle As String; sTreeTitle As String; persOrOrgs As Variant; bShowUserWG As Integer; bRecursiveSelect As Integer) As Variant
Синтакс Pascal: | function SelectPersonsOrganizations(mode: Integer; sDialogTitle: WideString; sTreeTitle: WideString; out persOrOrgs: COleVariant; bShowUserWG: Integer; bRecursiveSelect: Integer): COleVariant;

Описание:

Выводит диалог для выбора нескольких сотрудников и/или организаций

Результат: Возвращает True при удачном выполнении или False в случае отмены операции или ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | mode | значение, которое задает режим выбора объекта организационной структуры (можно выбирать сотрудника, абонента, сотрудника определенной организации и организацию, подробнее см. описание SelectInstance)
[in] | BSTR | sDialogTitle | заголовок диалога
[in] | BSTR | sTreeTitle | заголовок дерева объектов организационной структуры
[out] | VARIANT* | persOrOrgs | массив ссылок, содержащий ссылки на сотрудников или организации
[in] | long | bShowUserWG | флаг, задающий режим вывода поддерева рабочих групп текущего пользователя (возможные значения 0 и 1)
[in] | long | bRecursiveSelect | флаг, задающий режим множественного выбора (возможные значения 0 и 1)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


CreateApproval

Метод:

IAplAPI_Autorization::CreateApproval

Определение:

Синтакс IDL: | VARIANT CreateApproval(long instObject);
Синтакс Basic: | Function CreateApproval(instObject As Integer) As Variant
Синтакс Pascal: | function CreateApproval(instObject: Integer): COleVariant;

Описание:

Присваивает статус объекту, переданному с функцию. Выводит диалог для редактирования свойств статуса. Доступна для пользователя, с которым ассоциирован сотрудник.

Результат: Возвращает указатель на созданный статус или NULL в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instObject | объект, которому необходимо присвоить статус

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


LoadItemApproval

Метод:

IAplAPI_Autorization::LoadItemApproval

Определение:

Синтакс IDL: | VARIANT LoadItemApproval(long item, VARIANT* allApprovals);
Синтакс Basic: | Function LoadItemApproval(item As Integer; allApprovals As Variant) As Variant
Синтакс Pascal: | function LoadItemApproval(item: Integer; out allApprovals: COleVariant): COleVariant;

Описание:

Возвращает статусы, присвоенные объектам базы данных

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | item | объект базы данных, для которого запрашиваются статусы
[out] | VARIANT* | allApprovals | массив статусов объектов

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


ShowApproval

Метод:

IAplAPI_Autorization::ShowApproval

Определение:

Синтакс IDL: | VARIANT ShowApproval(long approval);
Синтакс Basic: | Function ShowApproval(approval As Integer) As Variant
Синтакс Pascal: | function ShowApproval(approval: Integer): COleVariant;

Описание:

Выводит диалог со свойствами статуса

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | approval | ссылка на статус

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


CreateApprovalEx

Метод:

IAplAPI_Autorization::CreateApprovalEx

Определение:

Синтакс IDL: | VARIANT CreateApprovalEx(long instObject, long status, BSTR role, long person, long apprOwner, BSTR level, DATE apprDate, BSTR signSystem, BSTR key, BSTR passWord);
Синтакс Basic: | Function CreateApprovalEx(instObject As Integer; status As Integer; role As String; person As Integer; apprOwner As Integer; level As String; apprDate As Date; signSystem As String; key As String; passWord As String) As Variant
Синтакс Pascal: | function CreateApprovalEx(instObject: Integer; status: Integer; role: WideString; person: Integer; apprOwner: Integer; level: WideString; apprDate: TDateTime; signSystem: WideString; key: WideString; passWord: WideString): COleVariant;

Описание:

Создает статус объекта (без вывода диалога).

Результат: Возвращает созданный статус или ноль в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instObject | ссылка на объект, которому присваивается статус
[in] | long | status | ссылка на присваиваемый статус
[in] | BSTR | role | роль сотрудника, присваивающего статус
[in] | long | person | ссылка на сотрудника, присваивающего статус
[in] | long | apprOwner | ссылка на сотрудника, являющегося владельцем статуса
[in] | BSTR | level | уровень
[in] | DATE | apprDate | дата присвоения статуса
[in] | BSTR | signSystem | система ЭЦП
[in] | BSTR | key | путь к файлу закрытого ключа
[in] | BSTR | passWord | пароль доступа к файлу закрытого ключа

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


SignDocument

Метод:

IAplAPI_Autorization::SignDocument

Определение:

Синтакс IDL: | VARIANT SignDocument(long doc, BSTR system, BSTR key, BSTR passWord, BSTR* sign, BSTR* hash, BSTR* openKey);
Синтакс Basic: | Function SignDocument(doc As Integer; system As String; key As String; passWord As String; sign As String; hash As String; openKey As String) As Variant
Синтакс Pascal: | function SignDocument(doc: Integer; system: WideString; key: WideString; passWord: WideString; out sign: WideString; out hash: WideString; out openKey: WideString): COleVariant;

Описание:

Создает ЭЦП документа.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | doc | ссылка на документ или версию документа
[in] | BSTR | system | система ЭЦП
[in] | BSTR | key | путь к файлу закрытого ключа
[in] | BSTR | passWord | пароль доступа к файлу закрытого ключа
[out] | BSTR* | sign | ЭЦП
[out] | BSTR* | hash | значение хэш-функции
[out] | BSTR* | openKey | открытый ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


CheckApproval

Метод:

IAplAPI_Autorization::CheckApproval

Определение:

Синтакс IDL: | VARIANT CheckApproval(long approval, long bShowResult);
Синтакс Basic: | Function CheckApproval(approval As Integer; bShowResult As Integer) As Variant
Синтакс Pascal: | function CheckApproval(approval: Integer; bShowResult: Integer): COleVariant;

Описание:

Проверяет ЭЦП документа, хранящуюся в статусе.

Результат: Возврщает следующие значения:
0 - подпись верна
1 - произошла ошибка во время выполнения программы
2 - неверный объект для подписи.\n(неверное значение хэш-функции)
3 - Неверная подпись
4 - неверный ключ пользователя
5 - подпись не задана

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | approval | статус документа
[in] | long | bShowResult | флаг, задающий режим работы функции: 0 - не выводить сообщение с результатами проверки 1 - выводить сообщение с результатами проверки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


GetPersonOfficials

Метод:

IAplAPI_Autorization::GetPersonOfficials

Определение:

Синтакс IDL: | VARIANT GetPersonOfficials(long person, VARIANT* officials, long bOwner);
Синтакс Basic: | Function GetPersonOfficials(person As Integer; officials As Variant; bOwner As Integer) As Variant
Синтакс Pascal: | function GetPersonOfficials(person: Integer; out officials: COleVariant; bOwner: Integer): COleVariant;

Описание:

Возвращает абонентов, которые связаны с сотрудником

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | person | указатель на сотрудника
[out] | VARIANT* | officials | массив, содержащий абонентов, связанных с сотрудником
[in] | long | bOwner | флаг, задающий режим формирования возвращаемого массива: 0 - в массив попадают абоненты, в которых сотрудник указан как во владельцах, так и в получателях 1 - в массив попадают абоненты, где сотрудник указан как владелец

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


ShowOfficialHistory

Метод:

IAplAPI_Autorization::ShowOfficialHistory

Определение:

Синтакс IDL: | VARIANT ShowOfficialHistory(long official, long showMode);
Синтакс Basic: | Function ShowOfficialHistory(official As Integer; showMode As Integer) As Variant
Синтакс Pascal: | function ShowOfficialHistory(official: Integer; showMode: Integer): COleVariant;

Описание:

Выводит диалог с историей абонента

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | official | ссылка на абонента, история которого запрашивается
[in] | long | showMode | флаг, задающий режим отображения истории (возможные значения 0 и 1)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


ShowPersonOfficials

Метод:

IAplAPI_Autorization::ShowPersonOfficials

Определение:

Синтакс IDL: | VARIANT ShowPersonOfficials(long person);
Синтакс Basic: | Function ShowPersonOfficials(person As Integer) As Variant
Синтакс Pascal: | function ShowPersonOfficials(person: Integer): COleVariant;

Описание:

Выводит диалог с абонентами сотрудника

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | person | ссылка на сотрудника, абоненты которого запрашиваются

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Autorization


IAplAPI_BProcess

Интерфейс: IAplAPI_BProcess

Методы для работы с бизнесс-процессам

GUID: {CA640AEA-8EE1-48F9-BC64-29859DC6EB8D}

Методы интерфейса:

Работа со словарем
Создание / Удаление
Поиск
Связь с другими объектами
Изменения (блокировки)
Прочее
Работа со словарем
LoadBPDictionary | Читает словарные данные
Создание / Удаление
AddBPToBP | Добавляет подпроцесс
CreateBP | Создает новый бизнесс-процесс
DeleteBP | Удаляет бизнесс-процесс
DeleteBPRelation | Удаляет связь между бизнесс-процессами
LoadAllBPResources | Возвращает ресурсы бизнесс-процесса
Поиск
FindBPAssociation | Проверяет, есть ли связь между бизнесс-процессом и объектом
FindBPById | Ищет бизнесс-процесс по обозначению
Связь с другими объектами
CreateBPAssociation | Связывает бизнесс-процесс с объектом
FindAssociatedBP | Возвращает связанные с объектом бизнесс-процессы
WhereUsedBP | Возвращает объекты, с которыми связан бизнесс-процесс
Изменения (блокировки)
CreateBPVersion | Создает версию бизнесс-процесса
GetAllBPVersion | Возвращает версии бизнесс-процесса
MakeBPVersionActive | Устанавливает активную версию бизнесс-процесса
CheckIn | Завершает редактирование бизнес-процесса
CheckOut | Берет бизнес-процесс на редактироввние.
UndoCheckOut | Отменяет редактирование бизнес-процесса
Прочее
LoadBPInfo | Читает атрибуты бизнесс-процесса в кэш
ShowBPProperties | Выводит диалог со свойствами бизнесс-процесса

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


LoadBPDictionary

Метод:

IAplAPI_BProcess::LoadBPDictionary

Определение:

Синтакс IDL: | VARIANT LoadBPDictionary();
Синтакс Basic: | Function LoadBPDictionary() As Variant
Синтакс Pascal: | function LoadBPDictionary(): COleVariant;

Описание:

Читает словарные данные (типы бизнес-процессов), относящиеся к бизнес-процессам.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


AddBPToBP

Метод:

IAplAPI_BProcess::AddBPToBP

Определение:

Синтакс IDL: | VARIANT AddBPToBP(long subBP, long baseBP);
Синтакс Basic: | Function AddBPToBP(subBP As Integer; baseBP As Integer) As Variant
Синтакс Pascal: | function AddBPToBP(subBP: Integer; baseBP: Integer): COleVariant;

Описание:

Добавляет в бизнесс-процесс подпроцесс. Бизнесс-процесс должен быть предварительно заблокирован на изменение с помощью функции CheckOut.

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | subBP | ссылка на подпроцесс
[in] | long | baseBP | ссылка на бизнес-процесс

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


CreateBP

Метод:

IAplAPI_BProcess::CreateBP

Определение:

Синтакс IDL: | VARIANT CreateBP(BSTR id, BSTR name, long type, long baseBP);
Синтакс Basic: | Function CreateBP(id As String; name As String; type As Integer; baseBP As Integer) As Variant
Синтакс Pascal: | function CreateBP(id: WideString; name: WideString; type: Integer; baseBP: Integer): COleVariant;

Описание:

Создает новый бизнесс-процесс

Результат: Возвращает ссылку на вновь созданный бизнесс-процесс или ноль в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение бизнесс-процесса
[in] | BSTR | name | наименование бизнесс-процесса
[in] | long | type | ссылка на тип бизнесс-процесса
[in] | long | baseBP | ссылка на бизнесс-процесс, в который вновь созданный добавляется как подпроцесс или ноль, если создается корневой бизнесс-процесс (если параметр задан, переданный процесс должен быть заблокирован на изменение с помощью функции CheckOut)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


DeleteBP

Метод:

IAplAPI_BProcess::DeleteBP

Определение:

Синтакс IDL: | VARIANT DeleteBP(long bp, long bDelSubBP);
Синтакс Basic: | Function DeleteBP(bp As Integer; bDelSubBP As Integer) As Variant
Синтакс Pascal: | function DeleteBP(bp: Integer; bDelSubBP: Integer): COleVariant;

Описание:

Удаляет бизнесс-процесс

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на удаляемый бизнесс-процесс
[in] | long | bDelSubBP | флаг, задающий режим работы функции: 0 - удалять рекурсивно все подпроцессы 1 - удалять только переданный бизнесс-процесс

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


DeleteBPRelation

Метод:

IAplAPI_BProcess::DeleteBPRelation

Определение:

Синтакс IDL: | VARIANT DeleteBPRelation(long subBP, long baseBP);
Синтакс Basic: | Function DeleteBPRelation(subBP As Integer; baseBP As Integer) As Variant
Синтакс Pascal: | function DeleteBPRelation(subBP: Integer; baseBP: Integer): COleVariant;

Описание:

Удаляет связь между бизнесс-процессами (удаляет у бизнесс-процесса из списка подпроцессов один из процессов, сам процесс не удаляется).

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | subBP | ссылка на подпроцесс
[in] | long | baseBP | ссылка на вышестоящий бизнесс-процесс

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


LoadAllBPResources

Метод:

IAplAPI_BProcess::LoadAllBPResources

Определение:

Синтакс IDL: | VARIANT LoadAllBPResources(long bp, VARIANT* resources);
Синтакс Basic: | Function LoadAllBPResources(bp As Integer; resources As Variant) As Variant
Синтакс Pascal: | function LoadAllBPResources(bp: Integer; out resources: COleVariant): COleVariant;

Описание:

Возвращает ресурсы бизнесс-процесса и считывает атрибуты объектов, связанных с ресурсами, в локальный кэш программы.

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс, ресурсы которого запрашиваются
[out] | VARIANT* | resources | массив, содержащий ссылки на ресурсы бизнесс-процесса

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


FindBPAssociation

Метод:

IAplAPI_BProcess::FindBPAssociation

Определение:

Синтакс IDL: | VARIANT FindBPAssociation(long instance, long bp);
Синтакс Basic: | Function FindBPAssociation(instance As Integer; bp As Integer) As Variant
Синтакс Pascal: | function FindBPAssociation(instance: Integer; bp: Integer): COleVariant;

Описание:

Проверяет, есть ли связь между бизнесс-процессом и объектом базы данных.

Результат: Вовращает связь между объектом и бизнесс-процессом или ноль, если связь не найдена или в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных
[in] | long | bp | ссылка на бизнесс-процесс

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


FindBPById

Метод:

IAplAPI_BProcess::FindBPById

Определение:

Синтакс IDL: | VARIANT FindBPById(BSTR bpId);
Синтакс Basic: | Function FindBPById(bpId As String) As Variant
Синтакс Pascal: | function FindBPById(bpId: WideString): COleVariant;

Описание:

Ищет в базе данных бизнесс-процесс по его обозначению.

Результат: Возвращает найденный бизнесс-процесс или ноль, если бизнесс-процесс не найден или в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | bpId | обозначение бизнесс-процесса

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


CreateBPAssociation

Метод:

IAplAPI_BProcess::CreateBPAssociation

Определение:

Синтакс IDL: | VARIANT CreateBPAssociation(long instance, long bp, BSTR assocId);
Синтакс Basic: | Function CreateBPAssociation(instance As Integer; bp As Integer; assocId As String) As Variant
Синтакс Pascal: | function CreateBPAssociation(instance: Integer; bp: Integer; assocId: WideString): COleVariant;

Описание:

Связывает бизнесс-процесс с объектом базы данных

Результат: Возвращает ссылку на связь бизнесс-процесса с объектом базы данных или ноль в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | объект базы данных, с которым создается ассоциация
[in] | long | bp | ссылка на бизнесс-процесс
[in] | BSTR | assocId | идентификатор связи

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


FindAssociatedBP

Метод:

IAplAPI_BProcess::FindAssociatedBP

Определение:

Синтакс IDL: | VARIANT FindAssociatedBP(long instance, VARIANT* ext, VARIANT* rels);
Синтакс Basic: | Function FindAssociatedBP(instance As Integer; ext As Variant; rels As Variant) As Variant
Синтакс Pascal: | function FindAssociatedBP(instance: Integer; out ext: COleVariant; out rels: COleVariant): COleVariant;

Описание:

Возвращает связанные с объектом базы данных бизнесс-процессы.

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных, для которого запрашиваются бизнесс-процессы
[out] | VARIANT* | ext | массив, содержащий ссылки на бизнесс-процессы
[out] | VARIANT* | rels | массив, содержащий ссылки на связи бизнесс-процессов с объектами базы данных

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


WhereUsedBP

Метод:

IAplAPI_BProcess::WhereUsedBP

Определение:

Синтакс IDL: | VARIANT WhereUsedBP(long bp, VARIANT* objects);
Синтакс Basic: | Function WhereUsedBP(bp As Integer; objects As Variant) As Variant
Синтакс Pascal: | function WhereUsedBP(bp: Integer; out objects: COleVariant): COleVariant;

Описание:

Возвращает объекты базы данных, с которыми ассоциирован бизнесс-процесс (если связи между объектами и бизнесс-процессами создавались с помощью пользовательского интерфейса модуля PDM, перечень объектов будет содержать изделия, версии изделия или вышестоящие бизнесс-процессы).

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс
[out] | VARIANT* | objects | массив, содержащий ссылки на объекты

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


CreateBPVersion

Метод:

IAplAPI_BProcess::CreateBPVersion

Определение:

Синтакс IDL: | VARIANT CreateBPVersion(long bp, BSTR verId, long bSetActive);
Синтакс Basic: | Function CreateBPVersion(bp As Integer; verId As String; bSetActive As Integer) As Variant
Синтакс Pascal: | function CreateBPVersion(bp: Integer; verId: WideString; bSetActive: Integer): COleVariant;

Описание:

Создает версию бизнесс-процесса на основе активной версии бизнесс-процесса или какой-либо определенной версии

Результат: Возвращает ссылку на вновь созданную версию бизнесс-процесса или ноль в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс (новая версия будет создаваться на основе текущей активной) или версию бизнесс-процесса
[in] | BSTR | verId | номер создаваемой версии или '-1', если создается следующая по порядку
[in] | long | bSetActive | флаг, задающий режим работы функции: 1 - делать новую версию бизнесс-процесса активной 0 - версию активной не делать

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


GetAllBPVersion

Метод:

IAplAPI_BProcess::GetAllBPVersion

Определение:

Синтакс IDL: | VARIANT GetAllBPVersion(long bp, VARIANT* versions);
Синтакс Basic: | Function GetAllBPVersion(bp As Integer; versions As Variant) As Variant
Синтакс Pascal: | function GetAllBPVersion(bp: Integer; out versions: COleVariant): COleVariant;

Описание:

Возвращает версии бизнесс-процесса

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс, версии которого запрашиваются
[out] | VARIANT* | versions | массив, содержащий ссылки на версии бизнесс-процессов

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


MakeBPVersionActive

Метод:

IAplAPI_BProcess::MakeBPVersionActive

Определение:

Синтакс IDL: | VARIANT MakeBPVersionActive(long bpVersion);
Синтакс Basic: | Function MakeBPVersionActive(bpVersion As Integer) As Variant
Синтакс Pascal: | function MakeBPVersionActive(bpVersion: Integer): COleVariant;

Описание:

Устанавливает активную версию бизнесс-процесса

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bpVersion | ссылка на версию бизнесс-процесса, которая делается активной

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


CheckIn

Метод:

IAplAPI_BProcess::CheckIn

Определение:

Синтакс IDL: | VARIANT CheckIn(long instance, long setActive);
Синтакс Basic: | Function CheckIn(instance As Integer; setActive As Integer) As Variant
Синтакс Pascal: | function CheckIn(instance: Integer; setActive: Integer): COleVariant;

Описание:

Завершает редактирование бизнес-процесса, при этом снимает блокировку на изменение с бизнес-процесса и создает в базе данных новую версию бизнес-процесс, если он изменился.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на бизнес-процесс, редактирование которого завершается
[in] | long | setActive | флаг, задающий режим работы функции: 0 - не делать новую версию активной 1 - сделать новую версию активной

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


CheckOut

Метод:

IAplAPI_BProcess::CheckOut

Определение:

Синтакс IDL: | VARIANT CheckOut(long bp, long checkOutSubBP);
Синтакс Basic: | Function CheckOut(bp As Integer; checkOutSubBP As Integer) As Variant
Синтакс Pascal: | function CheckOut(bp: Integer; checkOutSubBP: Integer): COleVariant;

Описание:

Берет бизнес-процесс на редактирование, при этом блокирует бизнес-процесс в базе данных на изменение другими пользователями.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнес-процесс
[in] | long | checkOutSubBP | флаг, задающий режим работы функции: 0 - не брать на редактирование подпроцессы 1 - взять на редактирование подпроцессы

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


UndoCheckOut

Метод:

IAplAPI_BProcess::UndoCheckOut

Определение:

Синтакс IDL: | VARIANT UndoCheckOut(long bp, long undoCheckOutSubBP);
Синтакс Basic: | Function UndoCheckOut(bp As Integer; undoCheckOutSubBP As Integer) As Variant
Синтакс Pascal: | function UndoCheckOut(bp: Integer; undoCheckOutSubBP: Integer): COleVariant;

Описание:

Отменяет редактирование (блокировку) бизнес-процесса.

Результат: Возврщает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнес-процесс
[in] | long | undoCheckOutSubBP | флаг, задающий режим работы функции: 0 - не отменять редактирование подпроцессов 1 - отменить редактирование подпроцессов

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


LoadBPInfo

Метод:

IAplAPI_BProcess::LoadBPInfo

Определение:

Синтакс IDL: | VARIANT LoadBPInfo(long bp, long bLoadSubBPInfo);
Синтакс Basic: | Function LoadBPInfo(bp As Integer; bLoadSubBPInfo As Integer) As Variant
Синтакс Pascal: | function LoadBPInfo(bp: Integer; bLoadSubBPInfo: Integer): COleVariant;

Описание:

Читает атрибуты бизнесс-процесса в локальный кэш программы

Результат: Возаращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс, атрибуты которого считываются в кэш или обновляются
[in] | long | bLoadSubBPInfo | флаг, задающий режим работы функции: 0 - не считывать атрибуты подпроцессов в кэш 1 - рекурсивно считывать атрибуты подпроцессов в кэш

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


ShowBPProperties

Метод:

IAplAPI_BProcess::ShowBPProperties

Определение:

Синтакс IDL: | VARIANT ShowBPProperties(long bp);
Синтакс Basic: | Function ShowBPProperties(bp As Integer) As Variant
Синтакс Pascal: | function ShowBPProperties(bp: Integer): COleVariant;

Описание:

Выводит диалог со свойствами бизнесс-процесса для просмотра или редактирования.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | bp | ссылка на бизнесс-процесс

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_BProcess


IAplAPI_Characteristic

Интерфейс: IAplAPI_Characteristic

Методы для работы с характеристиками и единицами измерения

GUID: {52185847-EFBD-4781-B76B-94EA7B1F684B}

Методы интерфейса:

Создание / Удаление
Работа со словарем
Чтение
Печать
Редактирование (блокировки)
Создание / Удаление
CreateCharacteristic | Выводит диалог для создания значения характеристики
CreateCopyCharacteristicVal | Копирует значенеи характеристики
CreateMeasuredCharacteristic | Создает значение числовой характеристики
CreateDescriptiveCharacteristic | Создает значение описательной характеристики
CreateDateTimeCharacteristic | Создает значение временной характеристики
DeleteCharacteristic | Удаляет характеристику
Работа со словарем
LoadCharacteristicDictionary | Читает словарные данные, относящиеся к характеристикам
GetCharacteristicById | Возвращает ссылку на характеристику по обозначению
GetCharacteristicType | Возвращает ссылку на тип характеристики
GetUnitById | Возвращает ссылку на единицу измерения по обозначению
GetUnitName | Форматирует наименование единицы измерения
SelectCharacteristic | Выводит диалог для выбора характеристики
SelectCharactUnionGroup | Выводит диалог для выбора групповой характеристики
Чтение
GetInstCharacteristic | Возвращает значение характеристики
FindAssociatedCharacteristic | Возвращает характеристики объекта
Печать
PrintCharacteristicValue | Форматирует наименование значения характеристики
Редактирование (блокировки)
CheckIn | Завершает редактирование характеристики
CheckOut | Берет характеристику на редактироввние
UndoCheckOut | Отменяет редактирование характеристики

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI


CreateCharacteristic

Метод:

IAplAPI_Characteristic::CreateCharacteristic

Определение:

Синтакс IDL: | VARIANT CreateCharacteristic(long item, long base_val, long new_char, long* val);
Синтакс Basic: | Function CreateCharacteristic(item As Integer; base_val As Integer; new_char As Integer; val As Integer) As Variant
Синтакс Pascal: | function CreateCharacteristic(item: Integer; base_val: Integer; new_char: Integer; out val: Integer): COleVariant;

Описание:

Выводит диалог для создания нового значения характеристики для объекта базы данных

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | item | объект, для которого создается характеристика
[in] | long | base_val | ссылка на значение характеристики, на базе которой создается новая характеристика (по умолчанию значение новой характеристики будет равно значению данной характеристики), может быть равна нулю
[in] | long | new_char | ссылка на описание характеристики в словаре системы, может быть равна нулю
[out] | long* | val | созданное значение характеристики для объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CreateCopyCharacteristicVal

Метод:

IAplAPI_Characteristic::CreateCopyCharacteristicVal

Определение:

Синтакс IDL: | VARIANT CreateCopyCharacteristicVal(long old_instance, long new_instance);
Синтакс Basic: | Function CreateCopyCharacteristicVal(old_instance As Integer; new_instance As Integer) As Variant
Синтакс Pascal: | function CreateCopyCharacteristicVal(old_instance: Integer; new_instance: Integer): COleVariant;

Описание:

Копирует значение характеристики из одной в другую или создает копию характеристики

Результат:

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | old_instance | ссылка на характеристику, из которой копируется значение
[in] | long | new_instance | ссылка на характеристику, в которую копируется значение (если передать ноль - создается новая)

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CreateMeasuredCharacteristic

Метод:

IAplAPI_Characteristic::CreateMeasuredCharacteristic

Определение:

Синтакс IDL: | VARIANT CreateMeasuredCharacteristic(long item, long characteristic, long type, double value, double maxDeviation, double minDeviation);
Синтакс Basic: | Function CreateMeasuredCharacteristic(item As Integer; characteristic As Integer; type As Integer; value As Double; maxDeviation As Double; minDeviation As Double) As Variant
Синтакс Pascal: | function CreateMeasuredCharacteristic(item: Integer; characteristic: Integer; type: Integer; value: Double; maxDeviation: Double; minDeviation: Double): COleVariant;

Описание:

Создает значение числовой характеристики для объекта

Результат: Возвращает созданное значение характеристики или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | item | ссылка на объект, которому задается характеристика
[in] | long | characteristic | ссылка на характеристику, значение которой задается
[in] | long | type | ссылка на тип характеристики
[in] | double | value | значение
[in] | double | maxDeviation | минимальный допуск на значение
[in] | double | minDeviation | максимальный допуск на значение

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CreateDescriptiveCharacteristic

Метод:

IAplAPI_Characteristic::CreateDescriptiveCharacteristic

Определение:

Синтакс IDL: | VARIANT CreateDescriptiveCharacteristic(long item, long characteristic, long type, BSTR value);
Синтакс Basic: | Function CreateDescriptiveCharacteristic(item As Integer; characteristic As Integer; type As Integer; value As String) As Variant
Синтакс Pascal: | function CreateDescriptiveCharacteristic(item: Integer; characteristic: Integer; type: Integer; value: WideString): COleVariant;

Описание:

Создает значение описательной характеристики для объекта

Результат: Возвращает созданное значение характеристики или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | item | ссылка на объект, которому задается характеристика
[in] | long | characteristic | ссылка на характеристику, значение которой задается
[in] | long | type | ссылка на тип характеристики
[in] | BSTR | value | значение

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CreateDateTimeCharacteristic

Метод:

IAplAPI_Characteristic::CreateDateTimeCharacteristic

Определение:

Синтакс IDL: | VARIANT CreateDateTimeCharacteristic(long item, long characteristic, long type, DATE value);
Синтакс Basic: | Function CreateDateTimeCharacteristic(item As Integer; characteristic As Integer; type As Integer; value As Date) As Variant
Синтакс Pascal: | function CreateDateTimeCharacteristic(item: Integer; characteristic: Integer; type: Integer; value: TDateTime): COleVariant;

Описание:

Создает значение временной характеристики для объекта

Результат: Возвращает созданное значение характеристики или 0 в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | item | ссылка на объект, которому задается характеристика
[in] | long | characteristic | ссылка на характеристику, значение которой задается
[in] | long | type | ссылка на тип характеристики
[in] | DATE | value | значение

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


DeleteCharacteristic

Метод:

IAplAPI_Characteristic::DeleteCharacteristic

Определение:

Синтакс IDL: | VARIANT DeleteCharacteristic(long val);
Синтакс Basic: | Function DeleteCharacteristic(val As Integer) As Variant
Синтакс Pascal: | function DeleteCharacteristic(val: Integer): COleVariant;

Описание:

Удаляет значение характеристики

Результат: Возвращает True при удачном выполнении и False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | val | ссылка на значение характеристики

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


LoadCharacteristicDictionary

Метод:

IAplAPI_Characteristic::LoadCharacteristicDictionary

Определение:

Синтакс IDL: | VARIANT LoadCharacteristicDictionary();
Синтакс Basic: | Function LoadCharacteristicDictionary() As Variant
Синтакс Pascal: | function LoadCharacteristicDictionary(): COleVariant;

Описание:

Читает в локальный кэш программы единицы измерения, типы характеристик, характеристики и группы характеристик (необходима, если программа работает с характеристиками или единицами измерения)

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


GetCharacteristicById

Метод:

IAplAPI_Characteristic::GetCharacteristicById

Определение:

Синтакс IDL: | VARIANT GetCharacteristicById(BSTR id);
Синтакс Basic: | Function GetCharacteristicById(id As String) As Variant
Синтакс Pascal: | function GetCharacteristicById(id: WideString): COleVariant;

Описание:

Производит поиск и возвращает ссылку на характеристику по ее обозначению

Результат: Возвращает ссылку на характеристику или ноль, если характеристика с переданным обозначением не найдена в базе данных

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | id | обозначение характеристики

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


GetCharacteristicType

Метод:

IAplAPI_Characteristic::GetCharacteristicType

Определение:

Синтакс IDL: | VARIANT GetCharacteristicType(BSTR type);
Синтакс Basic: | Function GetCharacteristicType(type As String) As Variant
Синтакс Pascal: | function GetCharacteristicType(type: WideString): COleVariant;

Описание:

Возвращает ссылку на тип характеристики по ее наименованию

Результат: Возвращает ссылку на тип характеристики или ноль, если тип с переданным наименованием не найден.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | type | наименование типа характеристики

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


GetUnitById

Метод:

IAplAPI_Characteristic::GetUnitById

Определение:

Синтакс IDL: | VARIANT GetUnitById(BSTR name);
Синтакс Basic: | Function GetUnitById(name As String) As Variant
Синтакс Pascal: | function GetUnitById(name: WideString): COleVariant;

Описание:

Возвращает ссылку на единицу измерения по ее обозначению

Результат: Возвращает единицу измерения или ноль, если единица измерения с таким обозначением не найдена

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | name | обозначение единицы измерения

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


GetUnitName

Метод:

IAplAPI_Characteristic::GetUnitName

Определение:

Синтакс IDL: | VARIANT GetUnitName(long unit, BSTR* name);
Синтакс Basic: | Function GetUnitName(unit As Integer; name As String) As Variant
Синтакс Pascal: | function GetUnitName(unit: Integer; out name: WideString): COleVariant;

Описание:

Форматирует наименование единицы измерения

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | unit | единица измерения
[out] | BSTR* | name | строка с отформатированным наименованием единицы измерения

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


SelectCharacteristic

Метод:

IAplAPI_Characteristic::SelectCharacteristic

Определение:

Синтакс IDL: | VARIANT SelectCharacteristic(long defaultCharact, long defaultGroup);
Синтакс Basic: | Function SelectCharacteristic(defaultCharact As Integer; defaultGroup As Integer) As Variant
Синтакс Pascal: | function SelectCharacteristic(defaultCharact: Integer; defaultGroup: Integer): COleVariant;

Описание:

Выводит диалог для выбора характеристики

Результат: Возвращает выбранную характеристику или ноль в случае ошибки или отмены операции

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | defaultCharact | ссылка на характеристику, которая будет выделена в диалоге выбора по умолчанию
[in] | long | defaultGroup | ссылка на объединение характеристик, которое будет выведена в диалоге выбора по умолчанию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


SelectCharactUnionGroup

Метод:

IAplAPI_Characteristic::SelectCharactUnionGroup

Определение:

Синтакс IDL: | VARIANT SelectCharactUnionGroup(long defaultCharactUnion, long defaultCharactGroup);
Синтакс Basic: | Function SelectCharactUnionGroup(defaultCharactUnion As Integer; defaultCharactGroup As Integer) As Variant
Синтакс Pascal: | function SelectCharactUnionGroup(defaultCharactUnion: Integer; defaultCharactGroup: Integer): COleVariant;

Описание:

Выводит диалог для выбора групповой характеристики

Результат: Возвращает выбранную характеристику или ноль в случае ошибки или отмены операции

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | defaultCharactUnion | ссылка на групповую характеристику, которая будет выделена в диалоге выбора по умолчанию
[in] | long | defaultCharactGroup | ссылка на объединение групповых характеристик, которое будет выведена в диалоге выбора по умолчанию

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


GetInstCharacteristic

Метод:

IAplAPI_Characteristic::GetInstCharacteristic

Определение:

Синтакс IDL: | VARIANT GetInstCharacteristic(long instance, long characteristic);
Синтакс Basic: | Function GetInstCharacteristic(instance As Integer; characteristic As Integer) As Variant
Синтакс Pascal: | function GetInstCharacteristic(instance: Integer; characteristic: Integer): COleVariant;

Описание:

Возвращает значение определенной характеристики, заданное для определенного объекта базы данных

Результат: Возвращает значение характеристики или ноль, если запрашиваемая характеристика не найдена у объекта

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | объект, для которого запрашивается определенная характеристика
[in] | long | characteristic | характеристика, значение которой ищется у объекта

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


FindAssociatedCharacteristic

Метод:

IAplAPI_Characteristic::FindAssociatedCharacteristic

Определение:

Синтакс IDL: | VARIANT FindAssociatedCharacteristic(long instance, VARIANT* outExt, VARIANT* outGroup);
Синтакс Basic: | Function FindAssociatedCharacteristic(instance As Integer; outExt As Variant; outGroup As Variant) As Variant
Синтакс Pascal: | function FindAssociatedCharacteristic(instance: Integer; out outExt: COleVariant; out outGroup: COleVariant): COleVariant;

Описание:

Возвращает значения характеристик объекта базы данных

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на объект базы данных, характеристики которого запрашиваются
[out] | VARIANT* | outExt | массив, содержащий значения характеристик
[out] | VARIANT* | outGroup | массив, содержащий значения групповых характеристик

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


PrintCharacteristicValue

Метод:

IAplAPI_Characteristic::PrintCharacteristicValue

Определение:

Синтакс IDL: | VARIANT PrintCharacteristicValue(long value, long unit, BSTR* name);
Синтакс Basic: | Function PrintCharacteristicValue(value As Integer; unit As Integer; name As String) As Variant
Синтакс Pascal: | function PrintCharacteristicValue(value: Integer; unit: Integer; out name: WideString): COleVariant;

Описание:

Форматирует наименование значения характеристики

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | value | значение характеристики
[in] | long | unit | единица измерения значения (может быть равна нулю)
[out] | BSTR* | name | строка, содержащая отформатированное значение характеристики

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CheckIn

Метод:

IAplAPI_Characteristic::CheckIn

Определение:

Синтакс IDL: | VARIANT CheckIn(long instance, long setActive);
Синтакс Basic: | Function CheckIn(instance As Integer; setActive As Integer) As Variant
Синтакс Pascal: | function CheckIn(instance: Integer; setActive: Integer): COleVariant;

Описание:

Завершает редактирование характеристики, при этом снимает блокировку на изменение с харктеристики и создает в базе данных новую версию характеристики, если значение изменилось.

Результат: Возвращает True при удачом выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на характеристику, редактирование которой завершается
[in] | long | setActive | флаг, задающий режим работы функции: 0 - не делать новую версию активной 1 - сделать новую версию активной

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


CheckOut

Метод:

IAplAPI_Characteristic::CheckOut

Определение:

Синтакс IDL: | VARIANT CheckOut(long instance);
Синтакс Basic: | Function CheckOut(instance As Integer) As Variant
Синтакс Pascal: | function CheckOut(instance: Integer): COleVariant;

Описание:

Берет характеристику на редактирование, при этом блокирует характеристику в базе данных на изменение другими пользователями.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на характеристику

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


UndoCheckOut

Метод:

IAplAPI_Characteristic::UndoCheckOut

Определение:

Синтакс IDL: | VARIANT UndoCheckOut(long instance);
Синтакс Basic: | Function UndoCheckOut(instance As Integer) As Variant
Синтакс Pascal: | function UndoCheckOut(instance: Integer): COleVariant;

Описание:

Отменяет редактирование (блокировку) характеристики

Результат: Возврщает True при удачном выполнении или False в случае ошибки

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | instance | ссылка на характеристику

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplPssAPI [image] Интерфейс IAplAPI_Characteristic


AplLongMap

Компонент: AplLongMap

Карта (Map) для связи уникальных ключей с типом целое число с полями с типом целое число

ProgID: APL_PSS_API.AplLongMap

Предоставляемые интерфейсы:

IAplLongMap Интерфейс для работы с картой Long - Long

Пример использования:

Dim map As AplLongMap
Dim key, idx, val As Variant

Set map = New AplLongMap

map.Add 55, 550
map.Add 33, 330
map.Add 22, 230
map.Add 44, 440
map.Add 11, 110

val = map.GetByKeyP(55)      'val равно '550'
idx = map.FindIndexByKey(33) 'idx равно 2

Set map = Nothing

Смотри также:

Библиотека APL_PSS_API


IAplLongMap

Интерфейс: IAplLongMap

Интерфейс для работы с картой Long - Long

GUID: {299806DE-EB94-431F-8C9C-D9780E720DD4}

Свойства интерфейса:

AutoSort | Включает или отключает автосортировку
Size | Возвращает текущий размер карты

Методы интерфейса:

Add | Добавляет новую комбинацию в карту
Remove | Удаляет элемент из карты
Clear | Очищает карту
GetByIndex | Возвращает ключ и значение по индексу
FindIndexByKey | Ищет индекс элемента
GetByKey | Возвращает значение по ключу
GetByKeyP | Возвращает значение по ключу.
Sort | Сортирует карту

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap


@metod_name

Свойство:

IAplLongMap::AutoSort

Тип: long

Доступ: Чтение - Запись

Описание:

Включает или отключает автосортировку при добавлении новых элементов.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


@metod_name

Свойство:

IAplLongMap::Size

Тип: long

Доступ: Только чтение

Описание:

Возвращает текущий размер карты.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


Add

Метод:

IAplLongMap::Add

Определение:

Синтакс IDL: | long Add(long key, long value);
Синтакс Basic: | Function Add(key As Integer; value As Integer) As Integer
Синтакс Pascal: | function Add(key: Integer; value: Integer): Integer;

Описание:

Добавляет новую комбинацию в карту

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | key | ключ
[in] | long | value | поле со значением

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


Remove

Метод:

IAplLongMap::Remove

Определение:

Синтакс IDL: | long Remove(long index);
Синтакс Basic: | Function Remove(index As Integer) As Integer
Синтакс Pascal: | function Remove(index: Integer): Integer;

Описание:

Удаляет элемент из карты

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | index | индекс элемента карты

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


Clear

Метод:

IAplLongMap::Clear

Определение:

Синтакс IDL: | void Clear();
Синтакс Basic: | Sub Clear()
Синтакс Pascal: | procedure Clear();

Описание:

Очищает карту

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


GetByIndex

Метод:

IAplLongMap::GetByIndex

Определение:

Синтакс IDL: | long GetByIndex(long index, long* key, long* value);
Синтакс Basic: | Function GetByIndex(index As Integer; key As Integer; value As Integer) As Integer
Синтакс Pascal: | function GetByIndex(index: Integer; out key: Integer; out value: Integer): Integer;

Описание:

Возвращает ключ и значение по индексу.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | index | индекс элемента
[out] | long* | key | ключ
[out] | long* | value | поле со значением

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


FindIndexByKey

Метод:

IAplLongMap::FindIndexByKey

Определение:

Синтакс IDL: | long FindIndexByKey(long key);
Синтакс Basic: | Function FindIndexByKey(key As Integer) As Integer
Синтакс Pascal: | function FindIndexByKey(key: Integer): Integer;

Описание:

Ищет индекс элемента по ключу.

Результат: Возвращает индекс элемента или -1 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


GetByKey

Метод:

IAplLongMap::GetByKey

Определение:

Синтакс IDL: | long GetByKey(long key);
Синтакс Basic: | Function GetByKey(key As Integer) As Integer
Синтакс Pascal: | function GetByKey(key: Integer): Integer;

Описание:

Возвращает значение по ключу. Отличается от GetByKeyP возвращаемым значением, в случае, если элемент не найден.

Результат: Возвращает значение элемента карты или -1 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


GetByKeyP

Метод:

IAplLongMap::GetByKeyP

Определение:

Синтакс IDL: | long GetByKeyP(long key);
Синтакс Basic: | Function GetByKeyP(key As Integer) As Integer
Синтакс Pascal: | function GetByKeyP(key: Integer): Integer;

Описание:

Возвращает значение по ключу. Отличается от GetByKey возвращаемым значением, в случае, если элемент не найден.

Результат: Возвращает значение элемента карты или 0 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


Sort

Метод:

IAplLongMap::Sort

Определение:

Синтакс IDL: | void Sort();
Синтакс Basic: | Sub Sort()
Синтакс Pascal: | procedure Sort();

Описание:

Сортирует карту по ключу.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplLongMap [image] Интерфейс IAplLongMap


AplStringMap

Компонент: AplStringMap

Карта (Map) для связи уникальных ключей с типом строка с полями с типом целое число

ProgID: APL_PSS_API.AplStringMap

Предоставляемые интерфейсы:

IAplStringMap Интерфейс для работы с картой String - Long

Пример использования:

Dim strmap As AplStringMap
Dim idx, val As Variant

Set strmap = New AplStringMap

strmap.Add epsilon, 5
strmap.Add alfa, 1
strmap.Add gamma, 3
strmap.Add betta, 2
strmap.Add delta, 4

val = strmap.GetByKeyP(betta)     'val равно 2
idx = strmap.FindIndexByKey(alfa) ' idx равно 0 т.к. после сортировки это первая запись

Set strmap = Nothing

Смотри также:

Библиотека APL_PSS_API


IAplStringMap

Интерфейс: IAplStringMap

Интерфейс для работы с картой String - Long

GUID: {16B33E03-9C28-48C8-B296-B1727CB0208E}

Свойства интерфейса:

Size Возвращает текущий размер карты

Методы интерфейса:

Add | Добавляет новую комбинацию в карту
Remove | Удаляет элемент из карты
Clear | Очищает карту
GetByIndex | Возвращает ключ и значение по индексу
SetByIndex | Установка значения по индексу
FindIndexByKey | Ищет индекс элемента
GetByKey | Возвращает значение по ключу
GetByKeyP | Возвращает значение по ключу.
Sort | Сортирует карту

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap


@metod_name

Свойство:

IAplStringMap::Size

Тип: long

Доступ: Только чтение

Описание:

Возвращает текущий размер карты.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


Add

Метод:

IAplStringMap::Add

Определение:

Синтакс IDL: | long Add(BSTR key, long value);
Синтакс Basic: | Function Add(key As String; value As Integer) As Integer
Синтакс Pascal: | function Add(key: WideString; value: Integer): Integer;

Описание:

Добавляет новую комбинацию в карту.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | key | ключ
[in] | long | value | поле со значением

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


Remove

Метод:

IAplStringMap::Remove

Определение:

Синтакс IDL: | long Remove(long index);
Синтакс Basic: | Function Remove(index As Integer) As Integer
Синтакс Pascal: | function Remove(index: Integer): Integer;

Описание:

Удаляет элемент из карты.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | index | индекс элемента карты

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


Clear

Метод:

IAplStringMap::Clear

Определение:

Синтакс IDL: | void Clear();
Синтакс Basic: | Sub Clear()
Синтакс Pascal: | procedure Clear();

Описание:

Очищает карту

Результат: Возвращает True при удачном выполнении или False в случае ошибки

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


GetByIndex

Метод:

IAplStringMap::GetByIndex

Определение:

Синтакс IDL: | long GetByIndex(long index, BSTR* key, long* value);
Синтакс Basic: | Function GetByIndex(index As Integer; key As String; value As Integer) As Integer
Синтакс Pascal: | function GetByIndex(index: Integer; out key: WideString; out value: Integer): Integer;

Описание:

Возвращает ключ и значение по индексу.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | index | индекс элемента
[out] | BSTR* | key | ключ
[out] | long* | value | поле со значением

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


SetByIndex

Метод:

IAplStringMap::SetByIndex

Определение:

Синтакс IDL: | long SetByIndex(long index, long value);
Синтакс Basic: | Function SetByIndex(index As Integer; value As Integer) As Integer
Синтакс Pascal: | function SetByIndex(index: Integer; value: Integer): Integer;

Описание:

Установка значения по индексу.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | long | index | индекс
[in] | long | value | новое значение

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


FindIndexByKey

Метод:

IAplStringMap::FindIndexByKey

Определение:

Синтакс IDL: | long FindIndexByKey(BSTR key);
Синтакс Basic: | Function FindIndexByKey(key As String) As Integer
Синтакс Pascal: | function FindIndexByKey(key: WideString): Integer;

Описание:

Ищет индекс элемента по ключу.

Результат: Возвращает индекс элемента или -1 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


GetByKey

Метод:

IAplStringMap::GetByKey

Определение:

Синтакс IDL: | long GetByKey(BSTR key);
Синтакс Basic: | Function GetByKey(key As String) As Integer
Синтакс Pascal: | function GetByKey(key: WideString): Integer;

Описание:

Возвращает значение по ключу. Отличается от GetByKeyP возвращаемым значением, в случае, если элемент не найден.

Результат: Возвращает значение элемента карты или -1 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


GetByKeyP

Метод:

IAplStringMap::GetByKeyP

Определение:

Синтакс IDL: | long GetByKeyP(BSTR key);
Синтакс Basic: | Function GetByKeyP(key As String) As Integer
Синтакс Pascal: | function GetByKeyP(key: WideString): Integer;

Описание:

Возвращает значение по ключу. Отличается от GetByKey возвращаемым значением, в случае, если элемент не найден.

Результат: Возвращает значение элемента карты или 0 в случае ошибки.

Параметры метода:

Специф. | Тип | Название | Описание
[in] | BSTR | key | ключ

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap


Sort

Метод:

IAplStringMap::Sort

Определение:

Синтакс IDL: | void Sort();
Синтакс Basic: | Sub Sort()
Синтакс Pascal: | procedure Sort();

Описание:

Сортирует карту по ключу.

Результат: Возвращает True при удачном выполнении или False в случае ошибки.

Смотри также:

Библиотека APL_PSS_API [image] Компонент AplStringMap [image] Интерфейс IAplStringMap